n8n: Cross-user Authorization Bypass in Dynamic Credential OAuth Endpoints
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.
Summary
n8n is an open source workflow automation platform. Prior to 1.123.43, 2.22.1, and 2.20.7, the OAuth1 and OAuth2 credential reconnect endpoints authorized access using credential:read rather than credential:update. An authenticated user with read-only access to a shared credential could initiate an OAuth reconnect flow and overwrite the stored token material for that credential with tokens bound to an external account they control. Workflows relying on the affected credential would subsequently execute under the attacker's OAuth identity, enabling data exfiltration to attacker-controlled external services and persistent takeover of shared integrations. This vulnerability is fixed in 1.123.43, 2.22.1, and 2.20.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | before 1.123.43; 2.0.0-rc.0 to before 2.20.7; 2.21.0 to before 2.21.1 | 1.123.43, 2.20.7, 2.21.1 | Patch available | CNA |
| — | n8n (npm) | before 1.123.43 | 1.123.43 | Patch available | GHSA-6h4j-wcr9-2vg7 |
| — | n8n (npm) | 2.21.0 to before 2.21.1 | 2.21.1 | Patch available | GHSA-6h4j-wcr9-2vg7 |
| — | n8n (npm) | 2.0.0-rc.0 to before 2.20.7 | 2.20.7 | Patch available | GHSA-6h4j-wcr9-2vg7 |
- n8n Vendorn8n Affected before 1.123.43; 2.0.0-rc.0 to before 2.20.7; 2.21.0 to before 2.21.1 Fixed in 1.123.43, 2.20.7, 2.21.1 Patch available CNA
- n8n (npm) Vendor— Affected before 1.123.43 Fixed in 1.123.43 Patch available GHSA-6h4j-wcr9-2vg7
- n8n (npm) Vendor— Affected 2.21.0 to before 2.21.1 Fixed in 2.21.1 Patch available GHSA-6h4j-wcr9-2vg7
- n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.20.7 Fixed in 2.20.7 Patch available GHSA-6h4j-wcr9-2vg7
Remediation
- Fix · CNA n8n (n8n-io) Fixed in 1.123.43, 2.20.7, 2.21.1
- Fix · GHSA-6h4j-wcr9-2vg7 n8n (npm) Fixed in 1.123.43 Advisory →
- Fix · GHSA-6h4j-wcr9-2vg7 n8n (npm) Fixed in 2.21.1 Advisory →
- Fix · GHSA-6h4j-wcr9-2vg7 n8n (npm) Fixed in 2.20.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45732
- 2026-10-03 Alias added: GHSA-6h4j-wcr9-2vg7
References
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-45732 · CVE Program
- CVE-2026-45732 · NVD
- FIRST EPSS
- GHSA-6h4j-wcr9-2vg7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences