electerm's encrypt method not safe enough
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-326.
Summary
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to 3.9.5, deterministic AES-192-CBC with a fixed zero IV, constant KDF salt, and no MAC leads to confidentiality and integrity failures for synced bookmark/profile data. Attackers can crack common passwords across installs and perform undetected ciphertext bit-flips to alter config/bookmarks. This vulnerability is fixed in 3.9.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| electerm | electerm | before 3.9.5 | 3.9.5 | Patch available | CNA |
| — | electerm (npm) | before 3.9.5 | 3.9.5 | Patch available | GHSA-g29v-q6h7-76wh |
- electerm Vendorelecterm Affected before 3.9.5 Fixed in 3.9.5 Patch available CNA
- electerm (npm) Vendor— Affected before 3.9.5 Fixed in 3.9.5 Patch available GHSA-g29v-q6h7-76wh
Remediation
- Fix · CNA electerm (electerm) Fixed in 3.9.5
- Fix · GHSA-g29v-q6h7-76wh electerm (npm) Fixed in 3.9.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-45787
- 2026-10-03 Alias added: GHSA-g29v-q6h7-76wh
References
Patch 2
More Electerm vulnerabilities
- TI-2020-14501 An issue was discovered in Electerm 1.3.22, allows attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2026-30086 electerm has Command Injection Vulnerability via runMac function CVSS 3.1CRITICAL 9.8
- TI-2026-30087 electerm has Command Injection Vulnerability via runLinux function CVSS 3.1CRITICAL 9.8
- TI-2026-31998 Unvalidated shell.openExternal in electerm allows arbitrary protocol execution via terminal link click CVSS 3.1CRITICAL 9.6
- TI-2026-32001 electerm: dangerous code can be run through links or command line CVSS 4.0CRITICAL 9.4
- TI-2026-33147 electerm: Local code through electerm's single-instance socket CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-45787 · CVE Program
- CVE-2026-45787 · NVD
- FIRST EPSS
- GHSA-g29v-q6h7-76wh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences