Flowise: Basic Auth Credentials Exposed via API
Priority HIGH 74CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.1.2, the checkBasicAuth endpoint validates credentials in plaintext without rate limiting and with direct comparison. This issue has been patched in version 3.1.2.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00231 14th percentileScored 2026-11-07
Fix Fixed Flowise (FlowiseAI): 3.1.2flowise (npm): 3.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| FlowiseAI | Flowise | before 3.1.2 | 3.1.2 | Patch available | CNA |
| — | flowise (npm) | before 3.1.2 | 3.1.2 | Patch available | GHSA-php6-83fg-gw3g |
- Flowise VendorFlowiseAI Affected before 3.1.2 Fixed in 3.1.2 Patch available CNA
- flowise (npm) Vendor— Affected before 3.1.2 Fixed in 3.1.2 Patch available GHSA-php6-83fg-gw3g
Remediation
- Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.2
- Fix · GHSA-php6-83fg-gw3g flowise (npm) Fixed in 3.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-46440
- 2026-10-03 Alias added: GHSA-php6-83fg-gw3g
References
More FlowiseAI Flowise vulnerabilities
- TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
- TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
- TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
- TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
Sources
- CVE-2026-46440 · CVE Program
- CVE-2026-46440 · NVD
- FIRST EPSS
- GHSA-php6-83fg-gw3g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences