Read the docs
TI-2026-34987 Aliases CVE-2026-47424GHSA-69j4-qvqr-hpw3

OpenAM Authenticated RCE via Groovy Sandbox Escape

Priority LOW 35CWE-693Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-693.

Summary

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, GroovySandboxValueFilter permits an authenticated server-side script author to escape the scripting sandbox despite the default class allow and deny lists. A user such as a sub-realm RealmAdmin who can create or edit a script in an executed context can invoke operating-system commands as the OpenAM application server account, crossing the realm-scoped administration boundary and compromising the JVM and every realm it serves. This issue is fixed in version 16.1.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00483 41st percentileScored 2026-11-07
Fix Fixed OpenAM (OpenIdentityPlatform): 16.1.1org.openidentityplatform.openam:openam-scripting (Maven): 16.1.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
OpenIdentityPlatformOpenAMbefore 16.1.116.1.1Patch availableCNA
—org.openidentityplatform.openam:openam-scripting (Maven)before 16.1.116.1.1Patch availableGHSA-69j4-qvqr-hpw3
  • OpenAM VendorOpenIdentityPlatform Affected before 16.1.1 Fixed in 16.1.1 Patch available CNA
  • org.openidentityplatform.openam:openam-scripting (Maven) Vendor— Affected before 16.1.1 Fixed in 16.1.1 Patch available GHSA-69j4-qvqr-hpw3

Remediation

  • Fix · CNA OpenAM (OpenIdentityPlatform) Fixed in 16.1.1
  • Fix · GHSA-69j4-qvqr-hpw3 org.openidentityplatform.openam:openam-scripting (Maven) Fixed in 16.1.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-47424
  2. 2026-10-03 Alias added: GHSA-69j4-qvqr-hpw3

References

  • TI-2025-20332 OpenDJ Denial of Service (Dos) using alias loop CVSS 4.0HIGH 8.7
  • TI-2026-25836 Pre-Authentication Remote Code Execution via `jato.clientSession` Deserialization in OpenAM CVSS 4.0CRITICAL 9.3
  • TI-2026-86693 Session token disclosure in OpenAM notification WebSocket CVSS 4.0CRITICAL 10.0
  • TI-2026-86692 Authentication bypass in OpenAM SAML login accepts unsigned assertions CVSS 4.0CRITICAL 9.3
  • TI-2026-86691 Privilege escalation in OpenAM via self-registration attribute bypass CVSS 4.0CRITICAL 9.3
  • TI-2026-86685 Unbounded Java deserialization in OpenAM enables denial of service CVSS 4.0HIGH 8.7
See all 54 →

Sources