CakePHP: View::element() is missing a path containment check
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Information disclosure, Code execution
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-22, CWE-98 and the CVSS impact.
Summary
CakePHP is a rapid development framework for PHP. In versions 4.5.11 and earlier, 4.6.0 through 4.6.3, 5.0.0 through 5.1.6, 5.2.0 through 5.2.12, and 5.3.0 through 5.3.5, View::_getElementFileName() does not check that the resolved element path is within the application/plugin view template paths. When element names are created with specifically crafted user-supplied data this weakness can be leveraged to include other PHP files on the server. Patched releases are available in 5.3.6, 5.2.13, 5.1.7, 4.6.4, and 4.5.11.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| cakephp | cakephp | 5.3.0 to before 5.3.6; 5.2.0 to before 5.2.13; 5.0.0 to before 5.1.7; 4.6.0 to before 4.6.4; before 4.5.11 | 5.3.6, 5.2.13, 5.1.7, 4.6.4, 4.5.11 | Patch available | CNA |
| — | cakephp/cakephp (Packagist) | 5.3.0 to before 5.3.6 | 5.3.6 | Patch available | GHSA-wpvj-hjcr-h3p2 |
| — | cakephp/cakephp (Packagist) | 5.2.0 to before 5.2.13 | 5.2.13 | Patch available | GHSA-wpvj-hjcr-h3p2 |
| — | cakephp/cakephp (Packagist) | 5.0.0 to before 5.1.7 | 5.1.7 | Patch available | GHSA-wpvj-hjcr-h3p2 |
| — | cakephp/cakephp (Packagist) | 4.6.0 to before 4.6.4 | 4.6.4 | Patch available | GHSA-wpvj-hjcr-h3p2 |
| — | cakephp/cakephp (Packagist) | before 4.5.11 | 4.5.11 | Patch available | GHSA-wpvj-hjcr-h3p2 |
- cakephp Vendorcakephp Affected 5.3.0 to before 5.3.6; 5.2.0 to before 5.2.13; 5.0.0 to before 5.1.7; 4.6.0 to before 4.6.4; before 4.5.11 Fixed in 5.3.6, 5.2.13, 5.1.7, 4.6.4, 4.5.11 Patch available CNA
- cakephp/cakephp (Packagist) Vendor— Affected 5.3.0 to before 5.3.6 Fixed in 5.3.6 Patch available GHSA-wpvj-hjcr-h3p2
- cakephp/cakephp (Packagist) Vendor— Affected 5.2.0 to before 5.2.13 Fixed in 5.2.13 Patch available GHSA-wpvj-hjcr-h3p2
- cakephp/cakephp (Packagist) Vendor— Affected 5.0.0 to before 5.1.7 Fixed in 5.1.7 Patch available GHSA-wpvj-hjcr-h3p2
- cakephp/cakephp (Packagist) Vendor— Affected 4.6.0 to before 4.6.4 Fixed in 4.6.4 Patch available GHSA-wpvj-hjcr-h3p2
- cakephp/cakephp (Packagist) Vendor— Affected before 4.5.11 Fixed in 4.5.11 Patch available GHSA-wpvj-hjcr-h3p2
Remediation
- Fix · CNA cakephp (cakephp) Fixed in 5.3.6, 5.2.13, 5.1.7, 4.6.4, 4.5.11
- Fix · GHSA-wpvj-hjcr-h3p2 cakephp/cakephp (Packagist) Fixed in 5.3.6 Advisory →
- Fix · GHSA-wpvj-hjcr-h3p2 cakephp/cakephp (Packagist) Fixed in 5.2.13 Advisory →
- Fix · GHSA-wpvj-hjcr-h3p2 cakephp/cakephp (Packagist) Fixed in 5.1.7 Advisory →
- Fix · GHSA-wpvj-hjcr-h3p2 cakephp/cakephp (Packagist) Fixed in 4.6.4 Advisory →
- Fix · GHSA-wpvj-hjcr-h3p2 cakephp/cakephp (Packagist) Fixed in 4.5.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-48820
- 2026-10-03 Alias added: GHSA-wpvj-hjcr-h3p2
References
More cakephp vulnerabilities
- TI-2010-04068 The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x… CVSS 2.0HIGH 7.5
- TI-2026-82995 Cookie leakage in CakePHP HTTP client cookie domain matching CVSS 4.0MEDIUM 6.3
- TI-2026-19037 CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting CVSS 3.1MEDIUM 5.4
- TI-2023-08901 Database Query::offset() and limit() vulnerable to SQL injection in cakephp CVSS 3.1CRITICAL 9.8
- TI-2026-54106 CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver CVSS 4.0CRITICAL 9.2
- TI-2026-55232 CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection CVSS 4.0CRITICAL 9.2
Sources
- CVE-2026-48820 · CVE Program
- CVE-2026-48820 · NVD
- FIRST EPSS
- GHSA-wpvj-hjcr-h3p2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences