LiteLLM: Authentication Bypass via Host Header Injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-290.
Summary
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, a Host-header parsing flaw in the LiteLLM proxy could, under specific conditions, allow unauthenticated access to protected management routes. The auth layer derived the effective route from request.url.path in litellm/proxy/auth/auth_utils.py::get_request_route(), which Starlette reconstructs from the Host header. A crafted Host could therefore make the auth gate evaluate a different route from the one FastAPI dispatched. This vulnerability is fixed in 1.84.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| BerriAI | litellm | before 1.84.0 | 1.84.0 | Patch available | CNA |
| — | litellm (PyPI) | before 1.84.0 | 1.84.0 | Patch available | GHSA-4xpc-pv4p-pm3w |
- litellm VendorBerriAI Affected before 1.84.0 Fixed in 1.84.0 Patch available CNA
- litellm (PyPI) Vendor— Affected before 1.84.0 Fixed in 1.84.0 Patch available GHSA-4xpc-pv4p-pm3w
Remediation
- Fix · CNA litellm (BerriAI) Fixed in 1.84.0
- Fix · GHSA-4xpc-pv4p-pm3w litellm (PyPI) Fixed in 1.84.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Exploit Intelligence | Affected | No fix yet |
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift AI (RHOAI) | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-49468
- 2026-10-03 Alias added: GHSA-4xpc-pv4p-pm3w
- 2026-11-06 Affected versions changed · Red Hat
References
Advisory 2
Other 7
- https://github.com/BerriAI/litellm/releases/tag/v1.84.0
- https://access.redhat.com/security/cve/CVE-2026-49468
- https://bugzilla.redhat.com/show_bug.cgi?id=2491520
- https://github.com/BerriAI/litellm
- https://github.com/pypa/advisory-database/tree/main/vulns/litellm/PYSEC-2026-388.yaml
- https://pypi.org/project/litellm
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-49468.json
More BerriAI Litellm vulnerabilities
- TI-2026-26015 Trivy ecosystem supply chain briefly compromised KEVCVSS 4.0CRITICAL 9.4
- TI-2026-30529 LiteLLM: SQL injection in Proxy API key verification KEVCVSS 4.0CRITICAL 9.3
- TI-2026-30582 LiteLLM: Authenticated command execution via MCP stdio test endpoints KEVCVSS 4.0HIGH 8.7
- TI-2026-42639 LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback KEVCVSS 4.0HIGH 8.8
- TI-2024-05340 Remote Code Execution in BerriAI/litellm CVSS 3.1CRITICAL 9.8
- TI-2024-02760 Server-Side Template Injection in BerriAI/litellm CVSS 3.0CRITICAL 9.8
Sources
- CVE-2026-49468 · CVE Program
- CVE-2026-49468 · NVD
- FIRST EPSS
- GHSA-4xpc-pv4p-pm3w · GitHub Advisory Database · CC BY 4.0
- CVE-2026-49468 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences