BuddyPress 14.4.0 Private Message IDOR via REST API user_id Parameter
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.
Summary
BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the messages REST API that allows authenticated attackers to access arbitrary private message threads by supplying a user_id parameter in the request. Attackers can pass another user's identifier to the get_item_permissions_check method, which validates the supplied user_id instead of the logged-in user and is reused by the update and delete handlers, to read, reply to, or delete any user's private messages.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| buddypress | BuddyPress | up to 14.4.0 | — | No fix listed | CNA |
| — | buddypress/buddypress (Packagist) | before 14.5.0 | 14.5.0 | Patch available | GHSA-j3j5-5m8v-7gvc |
- BuddyPress Vendorbuddypress Affected up to 14.4.0 Fixed in — No fix listed CNA
- buddypress/buddypress (Packagist) Vendor— Affected before 14.5.0 Fixed in 14.5.0 Patch available GHSA-j3j5-5m8v-7gvc
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:buddypress:buddypress:*:*:*:*:*:*:*:* | — | — | buddypress |
- cpe:2.3:a:buddypress:buddypress:*:*:*:*:*:*:*:* Versions — — ·buddypress
Remediation
- Fix · GHSA-j3j5-5m8v-7gvc buddypress/buddypress (Packagist) Fixed in 14.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-53673
- 2026-10-03 Alias added: GHSA-j3j5-5m8v-7gvc
- 2026-10-25 Priority changed: MEDIUM → LOW
References
More buddypress vulnerabilities
- TI-2021-04488 BuddyPress privilege escalation via REST API CVSS 3.1HIGH 8.8
- TI-2014-01473 The Group creation process in the Buddypress plugin before 1.9.2 for WordPress allows… CVSS 3.0MEDIUM 6.5
- TI-2024-09291 BuddyPress <= 14.1.0 - Authenticated (Subscriber+) Directory Traversal CVSS 3.1HIGH 8.1
- TI-2020-04300 Private data exposure via REST API in BuddyPress CVSS 3.1HIGH 8.0
- TI-2025-38345 WordPress BuddyPress plugin <= 14.3.4 - Broken Access Control vulnerability CVSS 3.1HIGH 7.5
- TI-2024-11112 BuddyPress <= 14.3.3 - Unauthenticated Arbitrary Shortcode Execution CVSS 3.1HIGH 7.3
Sources
- CVE-2026-53673 · CVE Program
- CVE-2026-53673 · NVD
- FIRST EPSS
- GHSA-j3j5-5m8v-7gvc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences