Read the docs
TI-2026-39201 Aliases CVE-2026-54305GHSA-2j5h-858j-5mpf

n8n: Cross-Tenant Credential Takeover via Dynamic Credentials EE Endpoints

Priority MEDIUM 41CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Information disclosure, Security bypass
Confidentiality · integrity · availability
High · High · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200 and CWE-284.

Summary

n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.2, three EE endpoints used by the Dynamic Credentials feature accepted any authenticated n8n session without performing per-resource ownership or scope checks on the target workflow or credential. An authenticated user with no project membership or credential sharing relationship could enumerate credential identifiers, names, and types referenced by any private workflow in the instance, initiate an OAuth authorization flow against another user's credential to overwrite its stored tokens with tokens bound to an account they control, or revoke another user's stored credential tokens entirely. Workflows relying on a hijacked credential would subsequently execute under the attacker's OAuth identity, enabling data exfiltration to attacker-controlled external services and persistent takeover of integrations. Token revocation would break affected workflows. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00374 31st percentileScored 2026-11-07
Fix Fixed n8n (n8n-io): 1.123.55, 2.25.7, 2.26.2n8n (npm): 1.123.55, 2.26.2, 2.25.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
n8nn8nbefore 1.123.55; 2.0.0-rc.0 to before 2.25.7; 2.26.0 to before 2.26.21.123.55, 2.25.7, 2.26.2Patch availableCNA
—n8n (npm)before 1.123.551.123.55Patch availableGHSA-2j5h-858j-5mpf
—n8n (npm)2.26.0 to before 2.26.22.26.2Patch availableGHSA-2j5h-858j-5mpf
—n8n (npm)2.0.0-rc.0 to before 2.25.72.25.7Patch availableGHSA-2j5h-858j-5mpf
  • n8n Vendorn8n Affected before 1.123.55; 2.0.0-rc.0 to before 2.25.7; 2.26.0 to before 2.26.2 Fixed in 1.123.55, 2.25.7, 2.26.2 Patch available CNA
  • n8n (npm) Vendor— Affected before 1.123.55 Fixed in 1.123.55 Patch available GHSA-2j5h-858j-5mpf
  • n8n (npm) Vendor— Affected 2.26.0 to before 2.26.2 Fixed in 2.26.2 Patch available GHSA-2j5h-858j-5mpf
  • n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.25.7 Fixed in 2.25.7 Patch available GHSA-2j5h-858j-5mpf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:*before 1.123.55; 2.0.0 to before 2.25.7; 2.26.0 to before 2.26.2Vulnerablen8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:* Versions before 1.123.55; 2.0.0 to before 2.25.7; 2.26.0 to before 2.26.2 Vulnerable ·n8n

Remediation

  • Fix · CNA n8n (n8n-io) Fixed in 1.123.55, 2.25.7, 2.26.2
  • Fix · GHSA-2j5h-858j-5mpf n8n (npm) Fixed in 1.123.55 Advisory →
  • Fix · GHSA-2j5h-858j-5mpf n8n (npm) Fixed in 2.26.2 Advisory →
  • Fix · GHSA-2j5h-858j-5mpf n8n (npm) Fixed in 2.25.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-54305
  2. 2026-10-03 Alias added: GHSA-2j5h-858j-5mpf

References

  • TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
  • TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
  • TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
  • TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
  • TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
See all 178 →

Sources