n8n: Credential Exfiltration via Permission Bypass
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.2, a member-level user with editor access to a shared workflow could reference credentials they do not own via specific public API endpoints. Credential ownership checks were only enforced partially leading to cross-user credential access. This issue affects instances where workflow sharing is enabled and at least one workflow has been shared with a member-level user as an Editor. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | before 1.123.55; 2.0.0-rc.0 to before 2.25.7; 2.26.0 to before 2.26.2 | 1.123.55, 2.25.7, 2.26.2 | Patch available | CNA |
| — | n8n (npm) | before 1.123.55 | 1.123.55 | Patch available | GHSA-pmqw-72cg-wx85 |
| — | n8n (npm) | 2.26.0 to before 2.26.2 | 2.26.2 | Patch available | GHSA-pmqw-72cg-wx85 |
| — | n8n (npm) | 2.0.0-rc.0 to before 2.25.7 | 2.25.7 | Patch available | GHSA-pmqw-72cg-wx85 |
- n8n Vendorn8n Affected before 1.123.55; 2.0.0-rc.0 to before 2.25.7; 2.26.0 to before 2.26.2 Fixed in 1.123.55, 2.25.7, 2.26.2 Patch available CNA
- n8n (npm) Vendor— Affected before 1.123.55 Fixed in 1.123.55 Patch available GHSA-pmqw-72cg-wx85
- n8n (npm) Vendor— Affected 2.26.0 to before 2.26.2 Fixed in 2.26.2 Patch available GHSA-pmqw-72cg-wx85
- n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.25.7 Fixed in 2.25.7 Patch available GHSA-pmqw-72cg-wx85
Remediation
- Fix · CNA n8n (n8n-io) Fixed in 1.123.55, 2.25.7, 2.26.2
- Fix · GHSA-pmqw-72cg-wx85 n8n (npm) Fixed in 1.123.55 Advisory →
- Fix · GHSA-pmqw-72cg-wx85 n8n (npm) Fixed in 2.26.2 Advisory →
- Fix · GHSA-pmqw-72cg-wx85 n8n (npm) Fixed in 2.25.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-54307
- 2026-10-03 Alias added: GHSA-pmqw-72cg-wx85
References
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-54307 · CVE Program
- CVE-2026-54307 · NVD
- FIRST EPSS
- GHSA-pmqw-72cg-wx85 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences