CakePHP: Open redirect weakness via backslash bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-601.
Summary
CakePHP Authentication is an authentication plugin for CakePHP that can also be used in PSR-7 based applications. Prior to 2.11.1, 3.3.6, and 4.1.1, the getLoginRedirect() method contains a weakness to backslash bypasses that allows redirect targets with attacker-controlled hostnames through the redirect query string parameter. This issue is fixed in versions 2.11.1, 3.3.6, and 4.1.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| cakephp | authentication | before 2.11.1; 3.0.0 to before 3.3.6; 4.0.0 to before 4.1.1 | 2.11.1, 3.3.6, 4.1.1 | Patch available | CNA |
| — | cakephp/authentication (Packagist) | 3.0.0 to before 3.3.6 | 3.3.6 | Patch available | GHSA-hhpq-7wg4-36jm |
| — | cakephp/authentication (Packagist) | 4.0.0 to before 4.1.1 | 4.1.1 | Patch available | GHSA-hhpq-7wg4-36jm |
| — | cakephp/authentication (Packagist) | before 2.11.1 | 2.11.1 | Patch available | GHSA-hhpq-7wg4-36jm |
- authentication Vendorcakephp Affected before 2.11.1; 3.0.0 to before 3.3.6; 4.0.0 to before 4.1.1 Fixed in 2.11.1, 3.3.6, 4.1.1 Patch available CNA
- cakephp/authentication (Packagist) Vendor— Affected 3.0.0 to before 3.3.6 Fixed in 3.3.6 Patch available GHSA-hhpq-7wg4-36jm
- cakephp/authentication (Packagist) Vendor— Affected 4.0.0 to before 4.1.1 Fixed in 4.1.1 Patch available GHSA-hhpq-7wg4-36jm
- cakephp/authentication (Packagist) Vendor— Affected before 2.11.1 Fixed in 2.11.1 Patch available GHSA-hhpq-7wg4-36jm
Remediation
- Fix · CNA authentication (cakephp) Fixed in 2.11.1, 3.3.6, 4.1.1
- Fix · GHSA-hhpq-7wg4-36jm cakephp/authentication (Packagist) Fixed in 3.3.6 Advisory →
- Fix · GHSA-hhpq-7wg4-36jm cakephp/authentication (Packagist) Fixed in 4.1.1 Advisory →
- Fix · GHSA-hhpq-7wg4-36jm cakephp/authentication (Packagist) Fixed in 2.11.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-55590
- 2026-10-03 Alias added: GHSA-hhpq-7wg4-36jm
References
Patch 6
- https://github.com/cakephp/authentication/pull/795
- https://github.com/cakephp/authentication/pull/796
- https://github.com/cakephp/authentication/pull/799
- https://github.com/cakephp/authentication/commit/1c1e29c7e8129cfbcae74558316ecd3ea50a8273
- https://github.com/cakephp/authentication/commit/df28ea4e712f1e5bd0e42be4a3c5c750ca50764d
- https://github.com/cakephp/authentication/commit/ee24bd48b9c3ef693dc9965de8f0cc8020a7052c
Advisory 2
More Cakephp vulnerabilities
- TI-2010-04068 The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x… CVSS 2.0HIGH 7.5
- TI-2026-19037 CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting CVSS 3.1MEDIUM 5.4
- TI-2023-08901 Database Query::offset() and limit() vulnerable to SQL injection in cakephp CVSS 3.1CRITICAL 9.8
- TI-2016-04142 The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their… CVSS 3.0HIGH 7.5
- TI-2015-06899 CakePHP 2.x and 3.x before 3.1.5 might allow remote attackers to bypass the CSRF… CVSS 3.0HIGH 8.8
- TI-2020-17913 A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-55590 · CVE Program
- CVE-2026-55590 · NVD
- FIRST EPSS
- GHSA-hhpq-7wg4-36jm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences