Contao crawler leaks auth credentials to external hosts
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Contao is an Open Source CMS. In versions 4.13.40 through 5.3.46 and 5.7.0-RC1 through 5.7.6, the crawler leaks auth credentials to external hosts. Contao's crawler tries to prevent confidential HTTP client options from being sent to external domains by creating a scoped client: full options for root page origins, cleaned options for everything else. The cleaner removes Cookie and Authorization headers, but it removes the non-Symfony option names basic_auth and bearer_auth instead of Symfony HttpClient's real auth_basic and auth_bearer options. When contao.crawl.default_http_client_options contains Basic or Bearer authentication for a protected staging/production site, those credentials remain in the "clean" client used for external links or configured additional URIs. An attacker who can get an external URL crawled, for example through a link on a crawled page while the broken-link checker is enabled, can receive the crawler credentials. This issue has been fixed in versions 5.3.47 and 5.7.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| contao | contao | 4.13.40 to before 5.3.47; 5.7.0-RC1 to before 5.7.7 | 5.3.47, 5.7.7 | Patch available | CNA |
| — | contao/contao (Packagist) | 4.13.0 to before 5.3.47 | 5.3.47 | Patch available | GHSA-3mr9-p497-58f6 |
| — | contao/contao (Packagist) | 5.4.0 to before 5.7.7 | 5.7.7 | Patch available | GHSA-3mr9-p497-58f6 |
| — | contao/core-bundle (Packagist) | 4.13.0 to before 5.3.47 | 5.3.47 | Patch available | GHSA-3mr9-p497-58f6 |
| — | contao/core-bundle (Packagist) | 5.4.0 to before 5.7.7 | 5.7.7 | Patch available | GHSA-3mr9-p497-58f6 |
- contao Vendorcontao Affected 4.13.40 to before 5.3.47; 5.7.0-RC1 to before 5.7.7 Fixed in 5.3.47, 5.7.7 Patch available CNA
- contao/contao (Packagist) Vendor— Affected 4.13.0 to before 5.3.47 Fixed in 5.3.47 Patch available GHSA-3mr9-p497-58f6
- contao/contao (Packagist) Vendor— Affected 5.4.0 to before 5.7.7 Fixed in 5.7.7 Patch available GHSA-3mr9-p497-58f6
- contao/core-bundle (Packagist) Vendor— Affected 4.13.0 to before 5.3.47 Fixed in 5.3.47 Patch available GHSA-3mr9-p497-58f6
- contao/core-bundle (Packagist) Vendor— Affected 5.4.0 to before 5.7.7 Fixed in 5.7.7 Patch available GHSA-3mr9-p497-58f6
Remediation
- Fix · CNA contao (contao) Fixed in 5.3.47, 5.7.7
- Fix · GHSA-3mr9-p497-58f6 contao/contao (Packagist) Fixed in 5.3.47 Advisory →
- Fix · GHSA-3mr9-p497-58f6 contao/contao (Packagist) Fixed in 5.7.7 Advisory →
- Fix · GHSA-3mr9-p497-58f6 contao/core-bundle (Packagist) Fixed in 5.3.47 Advisory →
- Fix · GHSA-3mr9-p497-58f6 contao/core-bundle (Packagist) Fixed in 5.7.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-55824
- 2026-10-03 Alias added: GHSA-3mr9-p497-58f6
References
Other 7
- https://github.com/contao/contao/security/advisories/GHSA-3mr9-p497-58f6
- https://github.com/contao/contao/commit/5bc6e3f900c439313df57aa561d0865792aafa05
- https://github.com/contao/contao/commit/80425d28cdf66280a209bd3f5bc31b1a76901a04
- https://contao.org/en/security-advisories/credentials-disclosure-in-the-crawler
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2026-55824.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2026-55824.yaml
- https://github.com/contao/contao
More contao vulnerabilities
- TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
- TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
- TI-2014-01453 Contao CMS through 3.2.4 has PHP Object Injection Vulnerabilities CVSS 3.1CRITICAL 9.8
- TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
- TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2026-55824 · CVE Program
- CVE-2026-55824 · NVD
- FIRST EPSS
- GHSA-3mr9-p497-58f6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences