Unrestricted file upload in Contao
Priority MEDIUM 62CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
Contao before 5.5.6 allows XSS via an SVG document. This affects (in contao/core-bundle in Composer) 4.x before 4.13.54, 5.0.x through 5.3.x before 5.3.30, and 5.4.x and 5.5..x before 5.5.6.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00338 27th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Contao (Contao): 4.13.54, 5.3.30, 5.5.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| contao | Contao | 4.0.0 to before 4.13.54; 5.0.0 to before 5.3.30; 5.4.0 to before 5.5.6 | 4.13.54, 5.3.30, 5.5.6 | Patch available | CNA |
- Contao Vendorcontao Affected 4.0.0 to before 4.13.54; 5.0.0 to before 5.3.30; 5.4.0 to before 5.5.6 Fixed in 4.13.54, 5.3.30, 5.5.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* | 4.0 to before 4.13.54; 5.0.0 to before 5.3.30; 5.4.0 to before 5.5.6 | Vulnerable | contao |
- cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions 4.0 to before 4.13.54; 5.0.0 to before 5.3.30; 5.4.0 to before 5.5.6 Vulnerable ·contao
Remediation
- Fix · CNA Contao (Contao) Fixed in 4.13.54, 5.3.30, 5.5.6
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45965
References
More Contao vulnerabilities
- TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
- TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
- TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
- TI-2024-30447 Remote command execution through file upload in contao/core-bundle CVSS 3.1HIGH 8.8
- TI-2019-14229 Contao 4.0 through 4.8.5 allows PHP local file inclusion. CVSS 3.1HIGH 8.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences