Read the docs
TI-2023-18600 Aliases CVE-2023-36806GHSA-4gpr-p634-922x

Contao cross site scripting vulnerability via input unit widget

Priority MEDIUM 62CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Contao is an open source content management system. Starting in version 4.0.0 and prior to versions 4.9.42, 4.13.28, and 5.1.10, it is possible for untrusted backend users to inject malicious code into headline fields in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify headline fields, or other fields using the input unit widget. Contao 4.9.42, 4.13.28, and 5.1.10 have a patch for this issue. As a workaround, disable the login for all untrusted back end users.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00637 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed contao (contao): 4.9.42, 4.13.28, 5.1.10contao/core-bundle (Packagist): 4.9.42, 4.13.28, 5.1.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
contaocontao4.0.0 to before 4.9.42; 4.10.0 to before 4.13.28; 5.0.0 to before 5.1.104.9.42, 4.13.28, 5.1.10Patch availableCNA
—contao/core-bundle (Packagist)4.0.0 to before 4.9.424.9.42Patch availableGHSA-4gpr-p634-922x
—contao/core-bundle (Packagist)4.10.0 to before 4.13.284.13.28Patch availableGHSA-4gpr-p634-922x
—contao/core-bundle (Packagist)5.0.0 to before 5.1.105.1.10Patch availableGHSA-4gpr-p634-922x
  • contao Vendorcontao Affected 4.0.0 to before 4.9.42; 4.10.0 to before 4.13.28; 5.0.0 to before 5.1.10 Fixed in 4.9.42, 4.13.28, 5.1.10 Patch available CNA
  • contao/core-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.9.42 Fixed in 4.9.42 Patch available GHSA-4gpr-p634-922x
  • contao/core-bundle (Packagist) Vendor— Affected 4.10.0 to before 4.13.28 Fixed in 4.13.28 Patch available GHSA-4gpr-p634-922x
  • contao/core-bundle (Packagist) Vendor— Affected 5.0.0 to before 5.1.10 Fixed in 5.1.10 Patch available GHSA-4gpr-p634-922x

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:*4.0.0 to before 4.9.42; 4.10.0 to before 4.13.28; 5.0.0 to before 5.1.10Vulnerablecontao
  • cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.9.42; 4.10.0 to before 4.13.28; 5.0.0 to before 5.1.10 Vulnerable ·contao

Remediation

  • Fix · CNA contao (contao) Fixed in 4.9.42, 4.13.28, 5.1.10
  • Fix · GHSA-4gpr-p634-922x contao/core-bundle (Packagist) Fixed in 4.9.42 Advisory →
  • Fix · GHSA-4gpr-p634-922x contao/core-bundle (Packagist) Fixed in 4.13.28 Advisory →
  • Fix · GHSA-4gpr-p634-922x contao/core-bundle (Packagist) Fixed in 5.1.10 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-36806
  2. 2026-10-03 Alias added: GHSA-4gpr-p634-922x
  3. 2026-10-25 EPSS moved to the 50th–90th percentile

References

  • TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
  • TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
  • TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
  • TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
  • TI-2024-30447 Remote command execution through file upload in contao/core-bundle CVSS 3.1HIGH 8.8
  • TI-2019-14229 Contao 4.0 through 4.8.5 allows PHP local file inclusion. CVSS 3.1HIGH 8.8
See all 31 →

Sources