Read the docs
TI-2019-08602 Aliases CVE-2019-11512GHSA-vq59-x6mq-4wgw

Contao 4.x allows SQL Injection.

Priority MEDIUM 45CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

Contao 4.x allows SQL Injection. Fixed in Contao 4.4.39 and Contao 4.7.5.

Why it matters now

EPSS 0.01462 73rd percentileScored 2026-11-07
Fix Fixed contao/contao (Packagist): 4.4.39, 4.7.5contao/core-bundle (Packagist): 4.4.39, 4.7.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—contao/contao (Packagist)4.1.0 to before 4.4.394.4.39Patch availableGHSA-vq59-x6mq-4wgw
—contao/contao (Packagist)4.5.0 to before 4.7.54.7.5Patch availableGHSA-vq59-x6mq-4wgw
—contao/core-bundle (Packagist)4.1.0 to before 4.4.394.4.39Patch availableGHSA-vq59-x6mq-4wgw
—contao/core-bundle (Packagist)4.5.0 to before 4.7.54.7.5Patch availableGHSA-vq59-x6mq-4wgw
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • contao/contao (Packagist) Vendor— Affected 4.1.0 to before 4.4.39 Fixed in 4.4.39 Patch available GHSA-vq59-x6mq-4wgw
  • contao/contao (Packagist) Vendor— Affected 4.5.0 to before 4.7.5 Fixed in 4.7.5 Patch available GHSA-vq59-x6mq-4wgw
  • contao/core-bundle (Packagist) Vendor— Affected 4.1.0 to before 4.4.39 Fixed in 4.4.39 Patch available GHSA-vq59-x6mq-4wgw
  • contao/core-bundle (Packagist) Vendor— Affected 4.5.0 to before 4.7.5 Fixed in 4.7.5 Patch available GHSA-vq59-x6mq-4wgw

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:*4.0.0 to before 4.4.39; 4.5.0 to before 4.7.5Vulnerablecontao
  • cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.4.39; 4.5.0 to before 4.7.5 Vulnerable ·contao

Remediation

  • Fix · GHSA-vq59-x6mq-4wgw contao/contao (Packagist) Fixed in 4.4.39 Advisory →
  • Fix · GHSA-vq59-x6mq-4wgw contao/contao (Packagist) Fixed in 4.7.5 Advisory →
  • Fix · GHSA-vq59-x6mq-4wgw contao/core-bundle (Packagist) Fixed in 4.4.39 Advisory →
  • Fix · GHSA-vq59-x6mq-4wgw contao/core-bundle (Packagist) Fixed in 4.7.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-11512
  2. 2026-10-03 Alias added: GHSA-vq59-x6mq-4wgw

References

  • TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
  • TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
  • TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
  • TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
  • TI-2024-30447 Remote command execution through file upload in contao/core-bundle CVSS 3.1HIGH 8.8
  • TI-2019-14229 Contao 4.0 through 4.8.5 allows PHP local file inclusion. CVSS 3.1HIGH 8.8
See all 31 →

Sources