Flowise - Cross-Workspace Information Disclosure via chatflows/apikey Endpoint
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Flowise before 3.1.2 contains an information disclosure vulnerability in the /api/v1/chatflows/apikey/:apikey endpoint. When the keyonly query parameter is omitted (the default), the endpoint returns not only the chatflows bound to the supplied API key but also all chatflows across every workspace that have no API key assigned, because the underlying query lacks any workspace filter. An attacker with a valid API key for one workspace can therefore retrieve the full ChatFlow configuration (including flowData with system prompts and node configurations, chatbotConfig, apiConfig, and credential IDs) of unprotected chatflows belonging to other workspaces.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| FlowiseAI | Flowise | before 3.1.2 | 3.1.2 | Patch available | CNA |
| — | flowise (npm) | before 3.1.2 | 3.1.2 | Patch available | GHSA-c2c9-mfw7-p8hw |
- Flowise VendorFlowiseAI Affected before 3.1.2 Fixed in 3.1.2 Patch available CNA
- flowise (npm) Vendor— Affected before 3.1.2 Fixed in 3.1.2 Patch available GHSA-c2c9-mfw7-p8hw
Remediation
- Fix · CNA Flowise (Flowise) Fixed in 3.1.2
- Fix · GHSA-c2c9-mfw7-p8hw flowise (npm) Fixed in 3.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-56268
- 2026-10-03 Alias added: GHSA-c2c9-mfw7-p8hw
References
More FlowiseAI Flowise vulnerabilities
- TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
- TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
- TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
- TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
Sources
- CVE-2026-56268 · CVE Program
- CVE-2026-56268 · NVD
- FIRST EPSS
- GHSA-c2c9-mfw7-p8hw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences