n8n - Cross-Site Scripting and Open Redirect in Form Node
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
n8n before 1.123.24, 2.10.4, and 2.12.0 (across its 1.x and 2.x branches) contains cross-site scripting and open redirect vulnerabilities in the Form Node due to unsanitized HTML description fields and overly permissive iframe sandbox policies. Authenticated users with workflow creation permissions can inject malicious scripts or redirect parameters to perform stored XSS attacks or phishing redirects against end users.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | before 1.123.24; 2.0.0-rc.0 to before 2.10.4; 2.11.0 to before 2.12.0 | 1.123.24, 2.10.4, 2.12.0 | Patch available | CNA |
| n8n | n8n | 2.0.0-rc.0 to before 2.10.4 | 2.10.4 | Patch available | CNA |
| n8n | n8n | before 1.123.24 | 1.123.24 | Patch available | CNA |
- n8n Vendorn8n Affected before 1.123.24; 2.0.0-rc.0 to before 2.10.4; 2.11.0 to before 2.12.0 Fixed in 1.123.24, 2.10.4, 2.12.0 Patch available CNA
- n8n Vendorn8n Affected 2.0.0-rc.0 to before 2.10.4 Fixed in 2.10.4 Patch available CNA
- n8n Vendorn8n Affected before 1.123.24 Fixed in 1.123.24 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* | before 1.123.24 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* | before 1.123.24; 2.0.0 to before 2.10.4 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* | 2.10.0 to before 2.10.4; 2.11.0 to before 2.12.0 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* | 2.11.0 to before 2.12.0 | Vulnerable | n8n |
- cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions before 1.123.24 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions before 1.123.24; 2.0.0 to before 2.10.4 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions 2.10.0 to before 2.10.4; 2.11.0 to before 2.12.0 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions 2.11.0 to before 2.12.0 Vulnerable ·n8n
Remediation
- Fix · CNA n8n (n8n) Fixed in 1.123.24, 2.10.4, 2.12.0
- Fix · CNA n8n (n8n) Fixed in 2.10.4
- Fix · CNA n8n (n8n) Fixed in 1.123.24
Timeline
- 2026-10-02 Threatist record created from CVE-2026-56354
- 2026-10-03 Alias added: GHSA-qmq2-xjjf-5ffp
- 2026-10-29 Affected versions changed · CNA
References
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-56354 · CVE Program
- CVE-2026-56354 · NVD
- FIRST EPSS
- GHSA-qmq2-xjjf-5ffp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences