Read the docs
TI-2026-40719 Aliases CVE-2026-56356GHSA-99wx-hwrx-8g4w

n8n - Stored Cross-Site Scripting in Chat Trigger Node Custom CSS Field

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Passive
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

n8n contains a stored cross-site scripting vulnerability in the Chat Trigger node's Custom CSS field due to a misconfiguration of the sanitize-html library. Affected releases are those before 1.123.27, the 2.0.0 through 2.13.2 line, and 2.14.0 (fixed in 1.123.27, 2.13.3, and 2.14.1). An authenticated user with permission to create or modify workflows can inject JavaScript that bypasses sanitization, resulting in stored XSS against any user who visits the public chat page.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0025 16th percentileScored 2026-11-07
Fix Fixed n8n (n8n): 1.123.27, 2.13.3, 2.14.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
n8nn8nbefore 1.123.27; 2.0.0-rc.0 to before 2.13.3; 2.14.0 to before 2.14.11.123.27, 2.13.3, 2.14.1Patch availableCNA
n8nn8n2.14.0 to before 2.14.12.14.1Patch availableCNA
n8nn8n2.0.0-rc.0 to before 2.13.32.13.3Patch availableCNA
  • n8n Vendorn8n Affected before 1.123.27; 2.0.0-rc.0 to before 2.13.3; 2.14.0 to before 2.14.1 Fixed in 1.123.27, 2.13.3, 2.14.1 Patch available CNA
  • n8n Vendorn8n Affected 2.14.0 to before 2.14.1 Fixed in 2.14.1 Patch available CNA
  • n8n Vendorn8n Affected 2.0.0-rc.0 to before 2.13.3 Fixed in 2.13.3 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:*before 1.123.27; 2.0.0 to before 2.13.3Vulnerablen8n
cpe:2.3:a:n8n:n8n:2.14.0:*:*:*:*:node.js:*:*2.14.0Vulnerablen8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:* Versions before 1.123.27; 2.0.0 to before 2.13.3 Vulnerable ·n8n
  • cpe:2.3:a:n8n:n8n:2.14.0:*:*:*:*:node.js:*:* Versions 2.14.0 Vulnerable ·n8n

Remediation

  • Fix · CNA n8n (n8n) Fixed in 1.123.27, 2.13.3, 2.14.1
  • Fix · CNA n8n (n8n) Fixed in 2.14.1
  • Fix · CNA n8n (n8n) Fixed in 2.13.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-56356
  2. 2026-10-03 Alias added: GHSA-99wx-hwrx-8g4w
  3. 2026-10-29 Affected versions changed · CNA

References

  • TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
  • TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
  • TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
  • TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
  • TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
See all 178 →

Sources