n8n: Shared Credential Header Leak via HTTP Request Pagination Expression
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
n8n is an open source workflow automation platform. Prior to 1.123.61, 2.27.4, and, 2.28.1, an authenticated member with use-only editor access to a shared workflow could read credential-populated headers exposed via the $request object inside an HTTP Request node's pagination expression and exfiltrate the secret through item data. This issue is fixed in versions 1.123.61, 2.27.4, and 2.28.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | 2.28.0 to before 2.28.1; 2.0.0-rc.0 to before 2.27.4; before 1.123.61 | 2.28.1, 2.27.4, 1.123.61 | Patch available | CNA |
| — | n8n (npm) | before 1.123.61 | 1.123.61 | Patch available | GHSA-q3j5-8vrg-4p9q |
| — | n8n (npm) | 2.28.0 to before 2.28.1 | 2.28.1 | Patch available | GHSA-q3j5-8vrg-4p9q |
| — | n8n (npm) | 2.0.0-rc.0 to before 2.27.4 | 2.27.4 | Patch available | GHSA-q3j5-8vrg-4p9q |
- n8n Vendorn8n Affected 2.28.0 to before 2.28.1; 2.0.0-rc.0 to before 2.27.4; before 1.123.61 Fixed in 2.28.1, 2.27.4, 1.123.61 Patch available CNA
- n8n (npm) Vendor— Affected before 1.123.61 Fixed in 1.123.61 Patch available GHSA-q3j5-8vrg-4p9q
- n8n (npm) Vendor— Affected 2.28.0 to before 2.28.1 Fixed in 2.28.1 Patch available GHSA-q3j5-8vrg-4p9q
- n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.27.4 Fixed in 2.27.4 Patch available GHSA-q3j5-8vrg-4p9q
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* | before 1.123.61 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* | before 1.123.61 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* | 2.0.0 to before 2.27.4 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* | 2.0.0 to before 2.27.4 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:2.28.0:*:*:*:community:node.js:*:* | 2.28.0 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:2.28.0:*:*:*:enterprise:node.js:*:* | 2.28.0 | Vulnerable | n8n |
- cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions before 1.123.61 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions before 1.123.61 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions 2.0.0 to before 2.27.4 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions 2.0.0 to before 2.27.4 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:2.28.0:*:*:*:community:node.js:*:* Versions 2.28.0 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:2.28.0:*:*:*:enterprise:node.js:*:* Versions 2.28.0 Vulnerable ·n8n
Remediation
- Fix · CNA n8n (n8n-io) Fixed in 2.28.1, 2.27.4, 1.123.61
- Fix · GHSA-q3j5-8vrg-4p9q n8n (npm) Fixed in 1.123.61 Advisory →
- Fix · GHSA-q3j5-8vrg-4p9q n8n (npm) Fixed in 2.28.1 Advisory →
- Fix · GHSA-q3j5-8vrg-4p9q n8n (npm) Fixed in 2.27.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-59209
- 2026-10-03 Alias added: GHSA-q3j5-8vrg-4p9q
References
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-59209 · CVE Program
- CVE-2026-59209 · NVD
- FIRST EPSS
- GHSA-q3j5-8vrg-4p9q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences