n8n - Permission Bypass via Expression Parser Mismatch in External Secrets
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.
Summary
n8n before versions 1.123.61, 2.27.4, and 2.28.1 contains a permission bypass vulnerability in external secrets handling caused by a mismatch between the static validation check and the runtime expression engine. An authenticated user with credential create or update permissions but without the externalSecret:list scope can embed external secret references into credentials in forms the static validation does not detect; these references resolve at workflow execution time, exposing secret values the user is not authorized to access. This issue only affects instances where an external secrets provider is configured and Advanced Permissions are in use.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | before 1.123.61 | 1.123.61 | Patch available | CNA |
| n8n | n8n | 2.28.0 to before 2.28.1 | 2.28.1 | Patch available | CNA |
| n8n | n8n | 2.0.0-rc.0 to before 2.27.4 | 2.27.4 | Patch available | CNA |
| — | n8n (npm) | before 1.123.61 | 1.123.61 | Patch available | GHSA-jp7m-xcgx-57qm |
| — | n8n (npm) | 2.28.0 to before 2.28.1 | 2.28.1 | Patch available | GHSA-jp7m-xcgx-57qm |
| — | n8n (npm) | 2.0.0-rc.0 to before 2.27.4 | 2.27.4 | Patch available | GHSA-jp7m-xcgx-57qm |
- n8n Vendorn8n Affected before 1.123.61 Fixed in 1.123.61 Patch available CNA
- n8n Vendorn8n Affected 2.28.0 to before 2.28.1 Fixed in 2.28.1 Patch available CNA
- n8n Vendorn8n Affected 2.0.0-rc.0 to before 2.27.4 Fixed in 2.27.4 Patch available CNA
- n8n (npm) Vendor— Affected before 1.123.61 Fixed in 1.123.61 Patch available GHSA-jp7m-xcgx-57qm
- n8n (npm) Vendor— Affected 2.28.0 to before 2.28.1 Fixed in 2.28.1 Patch available GHSA-jp7m-xcgx-57qm
- n8n (npm) Vendor— Affected 2.0.0-rc.0 to before 2.27.4 Fixed in 2.27.4 Patch available GHSA-jp7m-xcgx-57qm
Remediation
- Fix · CNA n8n (n8n) Fixed in 1.123.61
- Fix · CNA n8n (n8n) Fixed in 2.28.1
- Fix · CNA n8n (n8n) Fixed in 2.27.4
- Fix · GHSA-jp7m-xcgx-57qm n8n (npm) Fixed in 1.123.61 Advisory →
- Fix · GHSA-jp7m-xcgx-57qm n8n (npm) Fixed in 2.28.1 Advisory →
- Fix · GHSA-jp7m-xcgx-57qm n8n (npm) Fixed in 2.27.4 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
n8n 2.27.4, 2.28.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2026-42394 n8n - External Secrets Disclosure via Workflow Node ExpressionsPriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2026-59259
- 2026-10-03 Alias added: GHSA-jp7m-xcgx-57qm
- 2026-10-29 Affected versions changed · CNA
References
Advisory 2
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-59259 · CVE Program
- CVE-2026-59259 · NVD
- FIRST EPSS
- GHSA-jp7m-xcgx-57qm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences