Read the docs
TI-2026-42637 Aliases CVE-2026-59820GHSA-5jmr-gcrj-2c9q

LiteLLM: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Priority LOW 30CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
None · High · High
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat.

Summary

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.7-stable, LiteLLM Skills archive extraction did not sufficiently validate file paths from uploaded skill ZIP archives, allowing an authenticated user with access to LiteLLM LLM API routes or a key whose allowed_routes includes /v1/skills, anthropic_routes, or llm_api_routes to upload a crafted skill archive containing path traversal entries that could be written outside the intended extraction or staging directory. This issue is fixed in version 1.83.7-stable.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00587 48th percentileScored 2026-11-07
Fix Partial litellm (BerriAI): 1.83.7-stablelitellm (PyPI): 1.83.7Red Hat: 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
BerriAIlitellmbefore 1.83.7-stable1.83.7-stablePatch availableCNA
—litellm (PyPI)before 1.83.71.83.7Patch availableGHSA-5jmr-gcrj-2c9q
  • litellm VendorBerriAI Affected before 1.83.7-stable Fixed in 1.83.7-stable Patch available CNA
  • litellm (PyPI) Vendor— Affected before 1.83.7 Fixed in 1.83.7 Patch available GHSA-5jmr-gcrj-2c9q

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:litellm:litellm:*:*:*:*:*:*:*:*before 1.83.7VulnerableBerriAI
cpe:2.3:a:litellm:litellm:1.83.7:rc1:*:*:*:*:*:*1.83.7 rc1VulnerableBerriAI
  • cpe:2.3:a:litellm:litellm:*:*:*:*:*:*:*:* Versions before 1.83.7 Vulnerable ·BerriAI
  • cpe:2.3:a:litellm:litellm:1.83.7:rc1:*:*:*:*:*:* Versions 1.83.7 rc1 Vulnerable ·BerriAI

Remediation

  • Fix · CNA litellm (BerriAI) Fixed in 1.83.7-stable
  • Fix · GHSA-5jmr-gcrj-2c9q litellm (PyPI) Fixed in 1.83.7 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Exploit IntelligenceAffectedNo fix yet
Not affected: 3 products
  • Lightspeed Core
  • Red Hat Ansible Automation Platform 2
  • Red Hat OpenShift AI (RHOAI)

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-59820
  2. 2026-10-03 Alias added: GHSA-5jmr-gcrj-2c9q

References

  • TI-2026-26015 Trivy ecosystem supply chain briefly compromised KEVCVSS 4.0CRITICAL 9.4
  • TI-2026-30529 LiteLLM: SQL injection in Proxy API key verification KEVCVSS 4.0CRITICAL 9.3
  • TI-2026-30582 LiteLLM: Authenticated command execution via MCP stdio test endpoints KEVCVSS 4.0HIGH 8.7
  • TI-2026-42639 LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback KEVCVSS 4.0HIGH 8.8
  • TI-2024-05340 Remote Code Execution in BerriAI/litellm CVSS 3.1CRITICAL 9.8
  • TI-2024-02760 Server-Side Template Injection in BerriAI/litellm CVSS 3.0CRITICAL 9.8
See all 36 →

Sources