Metabase: Unsafe Deserialization of H2 Query Results
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
Metabase is an open-source business intelligence and embedded analytics tool. Prior to 1.58.15, 1.59.12, 1.60.6.3, and 1.61.1.4, Metabase instances with an H2 database connection, including the default sample database, deserialize arbitrary Java objects returned in H2 native query result columns of type OTHER without validation, allowing an authenticated user who can run native H2 queries to execute code on the Metabase server. This issue is fixed in versions 1.58.15, 1.59.12, 1.60.6.3, and 1.61.1.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Metabase | metabase | 1.58.0 to before 1.58.15; 1.59.0 to before 1.59.12; 1.60.0 to before 1.60.6.3; 1.61.0 to before 1.61.1.4 | 1.58.15, 1.59.12, 1.60.6.3, 1.61.1.4 | Patch available | CNA |
- metabase VendorMetabase Affected 1.58.0 to before 1.58.15; 1.59.0 to before 1.59.12; 1.60.0 to before 1.60.6.3; 1.61.0 to before 1.61.1.4 Fixed in 1.58.15, 1.59.12, 1.60.6.3, 1.61.1.4 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metabase:metabase:*:*:*:*:-:*:*:* | 0.58.0 to before 0.58.15; 0.59.0 to before 0.59.12; 0.60.0 to before 0.60.6.3; 0.61.0 to before 0.61.1.4 | Vulnerable | Metabase |
| cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* | 1.58.0 to before 1.58.15; 1.59.0 to before 1.59.12; 1.60.0 to before 1.60.6.3; 1.61.0 to before 1.61.1.4 | Vulnerable | Metabase |
- cpe:2.3:a:metabase:metabase:*:*:*:*:-:*:*:* Versions 0.58.0 to before 0.58.15; 0.59.0 to before 0.59.12; 0.60.0 to before 0.60.6.3; 0.61.0 to before 0.61.1.4 Vulnerable ·Metabase
- cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* Versions 1.58.0 to before 1.58.15; 1.59.0 to before 1.59.12; 1.60.0 to before 1.60.6.3; 1.61.0 to before 1.61.1.4 Vulnerable ·Metabase
Remediation
- Fix · CNA metabase (metabase) Fixed in 1.58.15, 1.59.12, 1.60.6.3, 1.61.1.4
Timeline
- 2026-10-02 Threatist record created from CVE-2026-59827
- 2026-11-04 EPSS moved to the 90th–95th percentile
References
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
- TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
- TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences