Next.js: Denial of Service in the Image Optimization API using SVGs
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-407.
Summary
Next.js is a React framework for building full-stack web applications. In versions 15.5.0 through 15.5.20 and 16.0.0 through 16.2.10, when self-hosting Next.js with the default image loader, the Image Optimization API can optimize remotely hosted images if configured (not enabled by default). If those images contain malicious content, they can cause CPU exhaustion in /_next/image endpoints.Only config.images.remotePatterns is affected, and just the patterns in that array, whereas config.images.unoptimized: true, config.images.loader: 'custom', and Vercel are not impacted. This issue has been fixed in versions 15.5.21 and 16.2.11.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vercel | next.js | 15.5.0 to before 15.5.21; 16.0.0 to before 16.2.11 | 15.5.21, 16.2.11 | Patch available | CNA |
| — | next (npm) | 15.5.0 to before 15.5.21 | 15.5.21 | Patch available | GHSA-q8wf-6r8g-63ch |
| — | next (npm) | 16.0.0 to before 16.2.11 | 16.2.11 | Patch available | GHSA-q8wf-6r8g-63ch |
- next.js Vendorvercel Affected 15.5.0 to before 15.5.21; 16.0.0 to before 16.2.11 Fixed in 15.5.21, 16.2.11 Patch available CNA
- next (npm) Vendor— Affected 15.5.0 to before 15.5.21 Fixed in 15.5.21 Patch available GHSA-q8wf-6r8g-63ch
- next (npm) Vendor— Affected 16.0.0 to before 16.2.11 Fixed in 16.2.11 Patch available GHSA-q8wf-6r8g-63ch
Remediation
- Fix · CNA next.js (vercel) Fixed in 15.5.21, 16.2.11
- Fix · GHSA-q8wf-6r8g-63ch next (npm) Fixed in 15.5.21 Advisory →
- Fix · GHSA-q8wf-6r8g-63ch next (npm) Fixed in 16.2.11 Advisory →
Red Hat 1 advisory
- RHSA-2026:54435 Released 2026-08-12 · Red Hat rating ImportantStreams for Apache Kafka 3.2.1 release and security update
- Streams for Apache Kafka 3.2.1
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Streams for Apache Kafka 3.2.1 | Fixed | RHSA-2026:54435 |
Not affected: 7 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Enterprise Linux AI (RHEL AI) 3
- Red Hat Trusted Artifact Signer
- streams for Apache Kafka 2
Timeline
- 2026-10-02 Threatist record created from CVE-2026-64644
- 2026-10-03 Alias added: GHSA-q8wf-6r8g-63ch
- 2026-11-03 Affected versions changed · Red Hat
References
Patch 2
More vercel Next.js vulnerabilities
- TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
- TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
- TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
- TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
- TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
- TI-2026-32490 Next.js: Server-side request forgery in applications using WebSocket upgrades CVSS 3.1HIGH 8.6
Sources
- CVE-2026-64644 · CVE Program
- CVE-2026-64644 · NVD
- FIRST EPSS
- GHSA-q8wf-6r8g-63ch · GitHub Advisory Database · CC BY 4.0
- CVE-2026-64644 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences