Read the docs
TI-2026-47760 Aliases CVE-2026-67602GHSA-368g-p5fp-42vr

phpIPAM < 1.8.2 Authentication Bypass via REST API Object Cache

Priority MEDIUM 49CWE-706Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
—
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA.

Summary

phpIPAM before 1.8.2 contains an authentication bypass vulnerability in the REST API that allows unauthenticated attackers to gain full API access by exploiting an insecure object cache keying mechanism. The cache is keyed by lookup value alone without including the searched column, enabling an entry written during an app_id lookup to satisfy a subsequent app_code lookup, allowing attackers to use the numeric database row identifier as an API token to read, write, and delete all IP address management records.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0064 50th percentileScored 2026-11-07
Fix Fixed phpipam (phpipam): 1.8.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
phpipamphpipambefore 1.8.21.8.2Patch availableCNA
  • phpipam Vendorphpipam Affected before 1.8.2 Fixed in 1.8.2 Patch available CNA

Remediation

  • Fix · CNA phpipam (phpipam) Fixed in 1.8.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-67602
  2. 2026-10-03 Alias added: GHSA-368g-p5fp-42vr
  3. 2026-10-23 EPSS moved to the 50th–90th percentile

References

  • TI-2024-09932 Cookie without Secure attribute in phpipam/phpipam CVSS 3.1HIGH 7.5
  • TI-2023-22036 Phpipam before v1.5.2 was discovered to contain a LDAP injection vulnerability via the… CVSS 3.1HIGH 7.5
  • TI-2023-01145 SQL Injection in phpipam/phpipam CVSS 3.1HIGH 7.2
  • TI-2024-00724 Improper Restriction of Excessive Authentication Attempts in phpipam/phpipam CVSS 3.1MEDIUM 5.9
  • TI-2024-27603 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/powerDNS/record-edit.php. CVSS 3.1HIGH 7.1
  • TI-2024-27600 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/widgets/edit.php CVSS 3.1HIGH 7.1
See all 56 →

Sources