Read the docs
TI-2026-48596 Aliases CVE-2026-69257GHSA-c6xh-wv4j-ppv5

Flowise: SSRF Protection Bypass via IPv4-Mapped IPv6 Addresses

Priority HIGH 68CWE-1389Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
—
Confidentiality · integrity · availability
High · High · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.

Summary

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, Flowise's HTTP security module httpSecurity.ts did not normalize IPv4-mapped IPv6 addresses such as ::ffff:127.0.0.1 and ::ffff:169.254.169.254 before checking them against the deny list. Because ipaddr.js reports these addresses as ipv6 while IPv4 CIDR deny-list entries are ipv4, isDeniedIP() skipped the IPv4 CIDR checks. An attacker who controls DNS resolution for a hostname used by the HTTP Node, API Chain, Document Loader, MCP tool, or other paths using secureAxiosRequest(), secureFetch(), or checkDenyList() could return a AAAA record for an IPv4-mapped target and cause requests to reach localhost, internal services, or cloud metadata endpoints. This issue is fixed in version 3.1.3.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00428 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Flowise (FlowiseAI): 3.1.3flowise (npm): 3.1.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
FlowiseAIFlowisebefore 3.1.33.1.3Patch availableCNA
—flowise (npm)before 3.1.33.1.3Patch availableGHSA-c6xh-wv4j-ppv5
  • Flowise VendorFlowiseAI Affected before 3.1.3 Fixed in 3.1.3 Patch available CNA
  • flowise (npm) Vendor— Affected before 3.1.3 Fixed in 3.1.3 Patch available GHSA-c6xh-wv4j-ppv5

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:*before 3.1.3VulnerableFlowiseAI
  • cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:* Versions before 3.1.3 Vulnerable ·FlowiseAI

Remediation

  • Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.3
  • Fix · GHSA-c6xh-wv4j-ppv5 flowise (npm) Fixed in 3.1.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-69257
  2. 2026-10-03 Alias added: GHSA-c6xh-wv4j-ppv5

References

  • TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
  • TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
  • TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
  • TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
  • TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
See all 127 →

Sources