Read the docs
TI-2026-49247 Aliases CVE-2026-70474GHSA-wch5-xp77-fxg4

Flowise: Cross-Workspace OAuth2 Credential Metadata Leak

Priority HIGH 68CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

Flowise is a drag-and-drop user interface for building customized large language model (LLM) flows. Prior to 3.1.3, Flowise has three OAuth2 credential endpoints that look up credentials by id alone with no workspaceId filter. The authorize, callback, and refresh handlers query the Credential table by id only; callback and refresh are whitelisted from authentication. This allows any authenticated user to initiate OAuth2 flows against credentials belonging to other workspaces, allows an unauthenticated attacker to forge OAuth2 callbacks to overwrite tokens in any credential, and allows an unauthenticated attacker to refresh tokens for any credential. The affected routes include /api/v1/oauth2-credential/authorize/<VICTIM_CREDENTIAL_UUID>, /api/v1/oauth2-credential/callback?code=ATTACKER_AUTH_CODE&state=<VICTIM_CREDENTIAL_UUID>, and /api/v1/oauth2-credential/refresh/<VICTIM_CREDENTIAL_UUID>. This issue is fixed in version 3.1.3.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00477 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Flowise (FlowiseAI): 3.1.3flowise (npm): 3.1.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
FlowiseAIFlowisebefore 3.1.33.1.3Patch availableCNA
—flowise (npm)before 3.1.33.1.3Patch availableGHSA-wch5-xp77-fxg4
  • Flowise VendorFlowiseAI Affected before 3.1.3 Fixed in 3.1.3 Patch available CNA
  • flowise (npm) Vendor— Affected before 3.1.3 Fixed in 3.1.3 Patch available GHSA-wch5-xp77-fxg4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:*before 3.1.3VulnerableFlowiseAI
  • cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:* Versions before 3.1.3 Vulnerable ·FlowiseAI

Remediation

  • Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.3
  • Fix · GHSA-wch5-xp77-fxg4 flowise (npm) Fixed in 3.1.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-70474
  2. 2026-10-03 Alias added: GHSA-wch5-xp77-fxg4

References

  • TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
  • TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
  • TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
  • TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
  • TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
See all 127 →

Sources