GetSimple CMS: Authenticated Stored Local File Inclusion (LFI) via page "template" field
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-98.
Summary
GetSimple CMS is a content management system (CMS), and GetSimple CMS CE is the community edition of that CMS. In versions 3.3.22 and prior, an authenticated user with page-editing rights can store an arbitrary filesystem path in a page's template attribute. On the public front-end, this value is passed unsanitized to a PHP include() when the page is rendered. Because the include path is never confined, this allows directory-traversal Local File Inclusion: arbitrary local files are included (and, if they contain PHP, executed) when any visitor requests the page. At time of publication, there are no publicly available patches.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GetSimpleCMS-CE | GetSimpleCMS-CE | up to 3.3.22 | — | No fix listed | CNA |
- GetSimpleCMS-CE VendorGetSimpleCMS-CE Affected up to 3.3.22 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:getsimple-ce:getsimple_cms:*:*:*:*:*:*:*:* | — | — | GetSimpleCMS-CE |
- cpe:2.3:a:getsimple-ce:getsimple_cms:*:*:*:*:*:*:*:* Versions — — ·GetSimpleCMS-CE
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-71426
References
More GetSimpleCMS-CE vulnerabilities
- TI-2024-36775 GetSimple CMS CE 3.3.19 suffers from arbitrary code execution in the template editing… CVSS 3.1CRITICAL 9.8
- TI-2026-38921 GetSimple CMS: Predictable Password Reset Password Allows Administrator Account Takeover CVSS 3.1CRITICAL 9.1
- TI-2025-30771 GetSimple CMS RCE in Edit component CVSS 4.0HIGH 8.6
- TI-2026-40846 GetSimple CMS: Missing CSRF protection in UpdateCE allows forging a privileged server-side update request CVSS 3.1CRITICAL 9.6
- TI-2026-40844 GetSimple CMS: CSRF, SSRF, and Unrestricted Zip Extraction CVSS 3.1CRITICAL 9.1
- TI-2024-36777 GetSimple CMS CE 3.3.19 is vulnerable to Server-Side Request Forgery (SSRF) in the backend plugin module. CVSS 3.1HIGH 8.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences