n8n before 2.32.1 Credential Restriction Bypass via AI/LLM Nodes
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
n8n versions before 2.32.1 fail to enforce the Allowed HTTP Request Domains allowlist in multiple AI and LLM nodes when user-supplied base or endpoint URLs are configured. Low-privileged workflow editors with use-only access to shared credentials can redirect requests to attacker-controlled hosts and exfiltrate credential secrets for reuse against underlying services.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| n8n | n8n | 2.32.0 to before 2.32.1 | 2.32.1 | Patch available | CNA |
| n8n | n8n | before 2.31.5 | 2.31.5 | Patch available | CNA |
- n8n Vendorn8n Affected 2.32.0 to before 2.32.1 Fixed in 2.32.1 Patch available CNA
- n8n Vendorn8n Affected before 2.31.5 Fixed in 2.31.5 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* | before 2.31.5 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* | before 2.31.5 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:2.32.0:*:*:*:community:node.js:*:* | 2.32.0 | Vulnerable | n8n |
| cpe:2.3:a:n8n:n8n:2.32.0:*:*:*:enterprise:node.js:*:* | 2.32.0 | Vulnerable | n8n |
- cpe:2.3:a:n8n:n8n:*:*:*:*:community:node.js:*:* Versions before 2.31.5 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:*:*:*:*:enterprise:node.js:*:* Versions before 2.31.5 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:2.32.0:*:*:*:community:node.js:*:* Versions 2.32.0 Vulnerable ·n8n
- cpe:2.3:a:n8n:n8n:2.32.0:*:*:*:enterprise:node.js:*:* Versions 2.32.0 Vulnerable ·n8n
Remediation
- Fix · CNA n8n (n8n-io) Fixed in 2.32.1
- Fix · CNA n8n (n8n-io) Fixed in 2.31.5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
n8n-io n8n 2.31.5, 2.32.1
16 records Highest priority Priority MEDIUM 4 MEDIUM, 12 LOW
Other records, highest priority first
- TI-2026-50992 n8n before 1.123.67 Arbitrary File Read via Send Email NodePriority MEDIUM 42
- TI-2026-50998 n8n before 2.32.1 Authentication Bypass via Token ExchangePriority MEDIUM 41
- TI-2026-50993 n8n before 1.123.67 Remote Code Execution via Git nodePriority MEDIUM 41
Timeline
- 2026-10-02 Threatist record created from CVE-2026-72771
- 2026-10-03 Alias added: GHSA-h7wc-28g5-h4g8
- 2026-10-29 Affected versions changed · CNA
References
More N8n vulnerabilities
- TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
- TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
- TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
- TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
- TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
- TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
Sources
- CVE-2026-72771 · CVE Program
- CVE-2026-72771 · NVD
- FIRST EPSS
- GHSA-h7wc-28g5-h4g8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences