Flowise before 3.1.3 Prompt Injection RCE via CSV Agent
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Flowise before 3.1.3 contains a regex-based Python code validator bypass in CSV and Airtable Agent nodes that allows unauthenticated attackers to inject malicious code via prompt injection. Attackers can exploit unblocked pandas functions like pd.read_json() to exfiltrate datasets, perform SSRF against internal services, or achieve code execution through the unauthenticated prediction API.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| FlowiseAI | Flowise | before 3.1.3 | 3.1.3 | Patch available | CNA |
| FlowiseAI | Flowise | before 3.1.3 | 3.1.3 | Patch available | CNA |
| — | flowise (npm) | before 3.1.3 | 3.1.3 | Patch available | GHSA-w7x8-q2gp-5cgg |
| — | flowise-components (npm) | before 3.1.3 | 3.1.3 | Patch available | GHSA-w7x8-q2gp-5cgg |
- Flowise VendorFlowiseAI Affected before 3.1.3 Fixed in 3.1.3 Patch available CNA
- Flowise VendorFlowiseAI Affected before 3.1.3 Fixed in 3.1.3 Patch available CNA
- flowise (npm) Vendor— Affected before 3.1.3 Fixed in 3.1.3 Patch available GHSA-w7x8-q2gp-5cgg
- flowise-components (npm) Vendor— Affected before 3.1.3 Fixed in 3.1.3 Patch available GHSA-w7x8-q2gp-5cgg
Remediation
- Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.3
- Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.3
- Fix · GHSA-w7x8-q2gp-5cgg flowise (npm) Fixed in 3.1.3 Advisory →
- Fix · GHSA-w7x8-q2gp-5cgg flowise-components (npm) Fixed in 3.1.3 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
FlowiseAI Flowise 3.1.3
9 records Highest priority Priority HIGH 4 HIGH, 5 MEDIUM
Other records, highest priority first
- TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via PuppeteerPriority HIGH 82
- TI-2026-51598 Flowise before 3.1.3 Code Injection via CSV Agent customReadCSVPriority HIGH 74
- TI-2026-51596 Flowise before 3.1.3 Sandbox Escape via Pandas MethodsPriority HIGH 72
Timeline
- 2026-10-02 Threatist record created from CVE-2026-73487
- 2026-10-03 Alias added: GHSA-x3jw-7gj7-qv6m
- 2026-10-07 Alias added: GHSA-w7x8-q2gp-5cgg
- 2026-10-07 Fix available: npm/[email protected], npm/[email protected] · GHSA-w7x8-q2gp-5cgg
- 2026-10-07 CVSS score added · GHSA-w7x8-q2gp-5cgg
- 2026-10-07 Weakness changed · GHSA-w7x8-q2gp-5cgg
- 2026-10-07 3 new references · GHSA-w7x8-q2gp-5cgg
References
More FlowiseAI Flowise vulnerabilities
- TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
- TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
- TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
- TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
Sources
- CVE-2026-73487 · CVE Program
- CVE-2026-73487 · NVD
- FIRST EPSS
- GHSA-w7x8-q2gp-5cgg · GitHub Advisory Database · CC BY 4.0
- GHSA-x3jw-7gj7-qv6m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences