CodeWhale before 0.8.64 Privilege Escalation via exec_shell_interact
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Hmbown | CodeWhale | 0.3.10 – 0.8.41 | — | No fix listed | CNA |
| Hmbown | CodeWhale | 0.3.10 to before 0.8.41 | 0.8.41 | Patch available | CNA |
| Hmbown | CodeWhale | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | CNA |
| Hmbown | CodeWhale | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | CNA |
| — | deepseek-tui (crates.io) | 0.3.10 – 0.8.41 | — | No fix listed | GHSA-g29h-pfmp-qp9r |
| — | deepseek-tui (npm) | 0.3.10 to before 0.8.41 | 0.8.41 | Patch available | GHSA-g29h-pfmp-qp9r |
| — | codewhale-tui (crates.io) | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | GHSA-g29h-pfmp-qp9r |
| — | codewhale (npm) | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | GHSA-g29h-pfmp-qp9r |
- CodeWhale VendorHmbown Affected 0.3.10 – 0.8.41 Fixed in — No fix listed CNA
- CodeWhale VendorHmbown Affected 0.3.10 to before 0.8.41 Fixed in 0.8.41 Patch available CNA
- CodeWhale VendorHmbown Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available CNA
- CodeWhale VendorHmbown Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available CNA
- deepseek-tui (crates.io) Vendor— Affected 0.3.10 – 0.8.41 Fixed in — No fix listed GHSA-g29h-pfmp-qp9r
- deepseek-tui (npm) Vendor— Affected 0.3.10 to before 0.8.41 Fixed in 0.8.41 Patch available GHSA-g29h-pfmp-qp9r
- codewhale-tui (crates.io) Vendor— Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available GHSA-g29h-pfmp-qp9r
- codewhale (npm) Vendor— Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available GHSA-g29h-pfmp-qp9r
Remediation
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.41
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.64
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.64
- Fix · GHSA-g29h-pfmp-qp9r deepseek-tui (npm) Fixed in 0.8.41 Advisory →
- Fix · GHSA-g29h-pfmp-qp9r codewhale-tui (crates.io) Fixed in 0.8.64 Advisory →
- Fix · GHSA-g29h-pfmp-qp9r codewhale (npm) Fixed in 0.8.64 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Hmbown CodeWhale 0.8.41, 0.8.64
9 records Highest priority Priority HIGH 7 HIGH, 2 MEDIUM
Other records, highest priority first
- TI-2026-53100 CodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOUPriority HIGH 79
- TI-2026-53143 CodeWhale before 0.8.64 Environment Variable Leak via js_executionPriority HIGH 77
- TI-2026-53141 CodeWhale before 0.8.64 Argument Injection via git_showPriority HIGH 72
Timeline
- 2026-10-02 Threatist record created from CVE-2026-75857
- 2026-10-03 Alias added: GHSA-g29h-pfmp-qp9r
- 2026-10-29 Affected versions changed · CNA
References
More Hmbown vulnerabilities
- TI-2026-53100 CodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOU CVSS 4.0CRITICAL 9.2
- TI-2026-53143 CodeWhale before 0.8.64 Environment Variable Leak via js_execution CVSS 4.0HIGH 8.7
- TI-2026-33165 CodeWhale: task_create Insecure Defaults Enable RCE via Prompt Injection in Project Files CVSS 3.1CRITICAL 9.6
- TI-2026-33110 CodeWhale: run_tests Tool Enables RCE via Malicious Repository Without Approval CVSS 3.1CRITICAL 9.6
- TI-2026-53141 CodeWhale before 0.8.64 Argument Injection via git_show CVSS 4.0HIGH 8.5
- TI-2026-53139 CodeWhale before 0.8.64 Remote Code Execution via allow_shell CVSS 4.0HIGH 8.5
Sources
- CVE-2026-75857 · CVE Program
- CVE-2026-75857 · NVD
- FIRST EPSS
- GHSA-g29h-pfmp-qp9r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences