CodeWhale before 0.8.64 Path Traversal via image_analyze symlink
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
CodeWhale versions before 0.8.64 contain a path traversal vulnerability in the image_analyze tool that fails to canonicalize symlinks before reading files. Attackers can create workspace symlinks pointing to external files with image extensions to leak file bytes to the vision endpoint without user approval.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Hmbown | CodeWhale | 0.8.32 to before 0.8.41 | 0.8.41 | Patch available | CNA |
| Hmbown | CodeWhale | 0.8.32 to before 0.8.41 | 0.8.41 | Patch available | CNA |
| Hmbown | CodeWhale | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | CNA |
| Hmbown | CodeWhale | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | CNA |
| — | deepseek-tui (crates.io) | 0.8.32 – 0.8.41 | — | No fix listed | GHSA-w7wx-5q49-r59w |
| — | deepseek-tui (npm) | 0.8.32 to before 0.8.41 | 0.8.41 | Patch available | GHSA-w7wx-5q49-r59w |
| — | codewhale-tui (crates.io) | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | GHSA-w7wx-5q49-r59w |
| — | codewhale (npm) | 0.8.41 to before 0.8.64 | 0.8.64 | Patch available | GHSA-w7wx-5q49-r59w |
- CodeWhale VendorHmbown Affected 0.8.32 to before 0.8.41 Fixed in 0.8.41 Patch available CNA
- CodeWhale VendorHmbown Affected 0.8.32 to before 0.8.41 Fixed in 0.8.41 Patch available CNA
- CodeWhale VendorHmbown Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available CNA
- CodeWhale VendorHmbown Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available CNA
- deepseek-tui (crates.io) Vendor— Affected 0.8.32 – 0.8.41 Fixed in — No fix listed GHSA-w7wx-5q49-r59w
- deepseek-tui (npm) Vendor— Affected 0.8.32 to before 0.8.41 Fixed in 0.8.41 Patch available GHSA-w7wx-5q49-r59w
- codewhale-tui (crates.io) Vendor— Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available GHSA-w7wx-5q49-r59w
- codewhale (npm) Vendor— Affected 0.8.41 to before 0.8.64 Fixed in 0.8.64 Patch available GHSA-w7wx-5q49-r59w
Remediation
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.41
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.41
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.64
- Fix · CNA CodeWhale (Hmbown) Fixed in 0.8.64
- Fix · GHSA-w7wx-5q49-r59w deepseek-tui (npm) Fixed in 0.8.41 Advisory →
- Fix · GHSA-w7wx-5q49-r59w codewhale-tui (crates.io) Fixed in 0.8.64 Advisory →
- Fix · GHSA-w7wx-5q49-r59w codewhale (npm) Fixed in 0.8.64 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Hmbown CodeWhale 0.8.41, 0.8.64
9 records Highest priority Priority HIGH 7 HIGH, 2 MEDIUM
Other records, highest priority first
- TI-2026-53100 CodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOUPriority HIGH 79
- TI-2026-53143 CodeWhale before 0.8.64 Environment Variable Leak via js_executionPriority HIGH 77
- TI-2026-53141 CodeWhale before 0.8.64 Argument Injection via git_showPriority HIGH 72
Timeline
- 2026-10-02 Threatist record created from CVE-2026-75914
- 2026-10-03 Alias added: GHSA-w7wx-5q49-r59w
References
More Hmbown vulnerabilities
- TI-2026-53100 CodeWhale before 0.8.64 SSRF Bypass via DNS Pinning TOCTOU CVSS 4.0CRITICAL 9.2
- TI-2026-53143 CodeWhale before 0.8.64 Environment Variable Leak via js_execution CVSS 4.0HIGH 8.7
- TI-2026-33165 CodeWhale: task_create Insecure Defaults Enable RCE via Prompt Injection in Project Files CVSS 3.1CRITICAL 9.6
- TI-2026-33110 CodeWhale: run_tests Tool Enables RCE via Malicious Repository Without Approval CVSS 3.1CRITICAL 9.6
- TI-2026-53141 CodeWhale before 0.8.64 Argument Injection via git_show CVSS 4.0HIGH 8.5
- TI-2026-53139 CodeWhale before 0.8.64 Remote Code Execution via allow_shell CVSS 4.0HIGH 8.5
Sources
- CVE-2026-75914 · CVE Program
- CVE-2026-75914 · NVD
- FIRST EPSS
- GHSA-w7wx-5q49-r59w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences