Read the docs
TI-2026-53837 Aliases CVE-2026-77084GHSA-fv4x-pgrr-xh57

n8n before 1.123.69 Remote Code Execution via Git Node Configuration Values

Priority LOW 37CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-78.

Summary

n8n before 1.123.69 (and 2.x before 2.33.4 / 2.34.1) contains a code execution vulnerability in the Git node. The Git node executed certain repository-local git configuration values without neutralizing them, so any subsequent Git node operation against a repository containing a malicious value would execute it as the n8n process user. This is not reachable through the Git node's own configuration controls and requires a separate file-write vulnerability elsewhere to plant the malicious value.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00689 52nd percentileScored 2026-11-07
Fix Fixed n8n (n8n-io): 1.123.69, 2.34.1, 2.33.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
n8nn8nbefore 1.123.691.123.69Patch availableCNA
n8nn8n2.34.0 to before 2.34.12.34.1Patch availableCNA
n8nn8n2.0.0 to before 2.33.42.33.4Patch availableCNA
  • n8n Vendorn8n Affected before 1.123.69 Fixed in 1.123.69 Patch available CNA
  • n8n Vendorn8n Affected 2.34.0 to before 2.34.1 Fixed in 2.34.1 Patch available CNA
  • n8n Vendorn8n Affected 2.0.0 to before 2.33.4 Fixed in 2.33.4 Patch available CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:*before 1.123.69; 2.0.0 to before 2.33.4Vulnerablen8n
cpe:2.3:a:n8n:n8n:2.34.0:*:*:*:*:node.js:*:*2.34.0Vulnerablen8n
  • cpe:2.3:a:n8n:n8n:*:*:*:*:*:node.js:*:* Versions before 1.123.69; 2.0.0 to before 2.33.4 Vulnerable ·n8n
  • cpe:2.3:a:n8n:n8n:2.34.0:*:*:*:*:node.js:*:* Versions 2.34.0 Vulnerable ·n8n

Remediation

  • Fix · CNA n8n (n8n-io) Fixed in 1.123.69
  • Fix · CNA n8n (n8n-io) Fixed in 2.34.1
  • Fix · CNA n8n (n8n-io) Fixed in 2.33.4

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    n8n-io n8n 2.33.4, 2.34.1

    17 records Highest priority Priority MEDIUM 2 MEDIUM, 15 LOW

    Other records, highest priority first

    • TI-2026-53821 n8n before 2.34.1 Remote Code Execution via Path TraversalPriority MEDIUM 41
    • TI-2026-53833 n8n before 1.123.69 Arbitrary File Read and Write via SnowflakePriority MEDIUM 40
    • TI-2026-53832 n8n before 2.34.1 Authorization Bypass via Custom Role DeletionPriority LOW 39
  • Release ·

    n8n-io n8n 1.123.69

    13 records Highest priority Priority MEDIUM 1 MEDIUM, 12 LOW

    Other records, highest priority first

    • TI-2026-53833 n8n before 1.123.69 Arbitrary File Read and Write via SnowflakePriority MEDIUM 40
    • TI-2026-53825 n8n before 1.123.69 Stored XSS via Form Completion PagePriority LOW 38
    • TI-2026-53828 n8n before 1.123.69 Expression Injection via Resource LocatorPriority LOW 37

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-77084
  2. 2026-10-03 Alias added: GHSA-fv4x-pgrr-xh57

References

  • TI-2025-42131 n8n Vulnerable to Remote Code Execution via Expression Injection KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-17560 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling CVSS 3.1CRITICAL 10.0
  • TI-2026-01167 Authenticated users can bypass the Expression sandbox mechanism to achieve full remote… CVSS 3.1CRITICAL 9.9
  • TI-2026-00644 Sandbox escape in n8n Python task runner allows for arbitrary code execution on the underlying host. CVSS 3.1CRITICAL 9.9
  • TI-2025-35293 An arbitrary file upload vulnerability in the Chat Trigger component of N8N v1.95.3… CVSS 3.1HIGH 8.8
  • TI-2023-12275 The n8n package 0.218.0 for Node.js allows Escalation of Privileges. CVSS 3.1HIGH 8.8
See all 178 →

Sources