CakePHP: SmtpTransport vulnerable to CRLF header injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
CakePHP is a rapid development framework for PHP. Prior to versions 4.5.12, 4.6.5, 5.1.8, 5.2.14, and 5.3.7 on their respective release lines, custom mail headers added with Message::setHeaders() or Message::addHeaders() do not have CRLF bytes removed, allowing header injection when user-controlled data is used in message headers. This issue is fixed in versions 4.5.12, 4.6.5, 5.1.8, 5.2.14, and 5.3.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| cakephp | cakephp | 4.5.0 to before 4.5.12; 4.6.0 to before 4.6.5; 5.0.0 to before 5.1.9; 5.2.0 to before 5.2.14; 5.3.0 to before 5.3.7 | 4.5.12, 4.6.5, 5.1.9, 5.2.14, 5.3.7 | Patch available | CNA |
| — | cakephp/cakephp (Packagist) | 4.5.0 to before 4.5.12 | 4.5.12 | Patch available | GHSA-2qh5-382h-3jpc |
| — | cakephp/cakephp (Packagist) | 4.6.0 to before 4.6.5 | 4.6.5 | Patch available | GHSA-2qh5-382h-3jpc |
| — | cakephp/cakephp (Packagist) | 5.0.0 to before 5.1.9 | 5.1.9 | Patch available | GHSA-2qh5-382h-3jpc |
| — | cakephp/cakephp (Packagist) | 5.2.0 to before 5.2.14 | 5.2.14 | Patch available | GHSA-2qh5-382h-3jpc |
| — | cakephp/cakephp (Packagist) | 5.3.0 to before 5.3.7 | 5.3.7 | Patch available | GHSA-2qh5-382h-3jpc |
- cakephp Vendorcakephp Affected 4.5.0 to before 4.5.12; 4.6.0 to before 4.6.5; 5.0.0 to before 5.1.9; 5.2.0 to before 5.2.14; 5.3.0 to before 5.3.7 Fixed in 4.5.12, 4.6.5, 5.1.9, 5.2.14, 5.3.7 Patch available CNA
- cakephp/cakephp (Packagist) Vendor— Affected 4.5.0 to before 4.5.12 Fixed in 4.5.12 Patch available GHSA-2qh5-382h-3jpc
- cakephp/cakephp (Packagist) Vendor— Affected 4.6.0 to before 4.6.5 Fixed in 4.6.5 Patch available GHSA-2qh5-382h-3jpc
- cakephp/cakephp (Packagist) Vendor— Affected 5.0.0 to before 5.1.9 Fixed in 5.1.9 Patch available GHSA-2qh5-382h-3jpc
- cakephp/cakephp (Packagist) Vendor— Affected 5.2.0 to before 5.2.14 Fixed in 5.2.14 Patch available GHSA-2qh5-382h-3jpc
- cakephp/cakephp (Packagist) Vendor— Affected 5.3.0 to before 5.3.7 Fixed in 5.3.7 Patch available GHSA-2qh5-382h-3jpc
Remediation
- Fix · CNA cakephp (cakephp) Fixed in 4.5.12, 4.6.5, 5.1.9, 5.2.14, 5.3.7
- Fix · GHSA-2qh5-382h-3jpc cakephp/cakephp (Packagist) Fixed in 4.5.12 Advisory →
- Fix · GHSA-2qh5-382h-3jpc cakephp/cakephp (Packagist) Fixed in 4.6.5 Advisory →
- Fix · GHSA-2qh5-382h-3jpc cakephp/cakephp (Packagist) Fixed in 5.1.9 Advisory →
- Fix · GHSA-2qh5-382h-3jpc cakephp/cakephp (Packagist) Fixed in 5.2.14 Advisory →
- Fix · GHSA-2qh5-382h-3jpc cakephp/cakephp (Packagist) Fixed in 5.3.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-77634
- 2026-10-03 Alias added: GHSA-2qh5-382h-3jpc
References
Other 6
- https://github.com/cakephp/cakephp/security/advisories/GHSA-2qh5-382h-3jpc
- https://github.com/cakephp/cakephp/commit/08188962bcd99a95da1e49f62e786f2d688f1e41
- https://github.com/cakephp/cakephp/commit/2afe42b02d8ddc5d442bca5e8bb61910a727646e
- https://github.com/cakephp/cakephp/commit/3e09dae6cbdc983754fa3a8e6aae74da102a3ea1
- https://github.com/cakephp/cakephp/commit/b67b622457362b075bb37e625a82af73a0b3c9c3
- https://github.com/cakephp/cakephp
More cakephp vulnerabilities
- TI-2010-04068 The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x… CVSS 2.0HIGH 7.5
- TI-2026-82995 Cookie leakage in CakePHP HTTP client cookie domain matching CVSS 4.0MEDIUM 6.3
- TI-2026-19037 CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting CVSS 3.1MEDIUM 5.4
- TI-2023-08901 Database Query::offset() and limit() vulnerable to SQL injection in cakephp CVSS 3.1CRITICAL 9.8
- TI-2026-54106 CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver CVSS 4.0CRITICAL 9.2
- TI-2026-55232 CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection CVSS 4.0CRITICAL 9.2
Sources
- CVE-2026-77634 · CVE Program
- CVE-2026-77634 · NVD
- FIRST EPSS
- GHSA-2qh5-382h-3jpc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences