multer vulnerable to Denial of Service via orphaned disk writes on aborted uploads
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
multer is a Node.js middleware for handling multipart/form-data uploads. In versions 2.2.0 through 2.3.0, when a request using disk storage is aborted mid-upload, file writes that complete after multer has already run its abort cleanup are not removed, so each aborted upload can leave an orphaned file on disk. A remote unauthenticated attacker can repeatedly start and abort uploads to accumulate orphaned files and exhaust disk space, causing a denial of service. The issue is fixed in multer 2.4.0, and users should upgrade to 2.4.0 or later.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| expressjs | multer | 2.2.0 to before 2.4.0 | 2.4.0 | Patch available | CNA |
| — | multer (npm) | 2.2.0 to before 2.4.0 | 2.4.0 | Patch available | GHSA-3pph-fpjx-jg34 |
- multer Vendorexpressjs Affected 2.2.0 to before 2.4.0 Fixed in 2.4.0 Patch available CNA
- multer (npm) Vendor— Affected 2.2.0 to before 2.4.0 Fixed in 2.4.0 Patch available GHSA-3pph-fpjx-jg34
Remediation
- Fix · CNA multer (multer) Fixed in 2.4.0
- Fix · GHSA-3pph-fpjx-jg34 multer (npm) Fixed in 2.4.0 Advisory →
Red Hat 5 advisories
- RHSA-2026:82151 Released 2026-10-13 · Red Hat rating CriticalAnsible automation portal Red Hat Enterprise Linux Images
- Red Hat Ansible Automation Platform 2.2 registry.redhat.io/ansible-automation-platform/bootc-automation-portal-rhel9
- RHSA-2026:79088 Released 2026-10-08 · Red Hat rating CriticalRed Hat Developer Hub 1.10.5 release.
- Red Hat Developer Hub 1.10 registry.redhat.io/rhdh/rhdh-hub-rhel9, registry.redhat.io/rhdh/rhdh-rhel9-operator
- RHSA-2026:76788 Released 2026-10-06 · Red Hat rating CriticalRed Hat Developer Hub 1.10.5 Plugin Catalog GA plugins release.
- Red Hat Developer Hub 1.10 registry.redhat.io/rhdh/red-hat-developer-hub-backstage-plugin-lightspeed, registry.redhat.io/rhdh/red-hat-developer-hub-backstage-plugin-lightspeed-backend, registry.redhat.io/rhdh/red-hat-developer-hub-backstage-plugin-orchestrator +4
Show 2 more Red Hat advisories
- RHSA-2026:72722 Released 2026-09-28 · Red Hat rating ImportantAnsible plug-ins for Red Hat Developer Hub Product Release Update
- Red Hat Ansible Automation Platform 2.2 registry.redhat.io/ansible-automation-platform/automation-portal
- RHSA-2026:72712 Released 2026-09-28 · Red Hat rating ImportantAnsible plug-ins for Red Hat Developer Hub Product Release Update
- Red Hat Ansible Automation Platform 2.1 registry.redhat.io/ansible-automation-platform/automation-portal
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2.1 | Fixed | RHSA-2026:72712 |
| Red Hat Ansible Automation Platform 2.2 | Fixed | RHSA-2026:72722, RHSA-2026:82151 |
| Red Hat Developer Hub 1.10 | Fixed | RHSA-2026:76788, RHSA-2026:79088 |
Not affected: 2 products
- Red Hat 3scale API Management Platform 2
- Red Hat Developer Hub 1.10
Timeline
- 2026-10-02 Threatist record created from CVE-2026-88932
- 2026-10-03 Alias added: GHSA-3pph-fpjx-jg34
- 2026-10-07 Fix available: RHSA-2026:76788 · Red Hat
- 2026-10-07 Fix available: Red Hat Developer Hub 1.10 · Red Hat
- 2026-10-09 Fix available: RHSA-2026:79088 · Red Hat
- 2026-10-09 Affected versions changed · Red Hat
- 2026-10-13 Affected versions changed · Red Hat
- 2026-10-13 Fix available: RHSA-2026:82151 · Red Hat
References
Other 5
More expressjs vulnerabilities
- TI-2024-08602 Open redirect in expressjs express CVSS 3.1MEDIUM 4.7
- TI-2026-03033 Multer vulnerable to Denial of Service via uncontrolled recursion CVSS 4.0HIGH 8.7
- TI-2026-02853 Multer vulnerable to Denial of Service via incomplete cleanup CVSS 4.0HIGH 8.7
- TI-2026-01995 Multer vulnerable to Denial of Service via resource exhaustion CVSS 4.0HIGH 8.7
- TI-2025-31125 Multer vulnerable to Denial of Service via unhandled exception CVSS 4.0HIGH 8.7
- TI-2025-30337 Multer vulnerable to Denial of Service from maliciously crafted requests CVSS 3.1HIGH 7.5
Sources
- CVE-2026-88932 · CVE Program
- CVE-2026-88932 · NVD
- FIRST EPSS
- GHSA-3pph-fpjx-jg34 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-88932 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences