Flowise before 3.1.4 Denial of Service via text-to-speech/abort
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
Flowise versions before 3.1.4 contain an unauthenticated denial of service vulnerability in the /api/v1/text-to-speech/abort endpoint that accepts user-supplied chatflowId and chatId without ownership verification. Attackers can terminate active chatflow predictions for any user by submitting requests with known chatflow and chat identifiers, causing targeted service disruption.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
FlowiseAI Flowise 3.1.4
3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2026-61547 Flowise before 3.1.4 Broken Access Control via organizationuserPriority MEDIUM 60
- TI-2026-61548 Flowise before 3.1.4 Cross-Workspace Credential IDOR via node-load-methodPriority LOW 27
Timeline
- 2026-10-02 Threatist record created from CVE-2026-90535
- 2026-10-03 Alias added: GHSA-4xpg-6vjv-3v64
References
More FlowiseAI Flowise vulnerabilities
- TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
- TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
- TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
- TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
Sources
- CVE-2026-90535 · CVE Program
- CVE-2026-90535 · NVD
- FIRST EPSS
- GHSA-4xpg-6vjv-3v64 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences