Flowise before 3.1.4 NoSQL Injection via sessionId
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Flowise before 3.1.4 fails to sanitize the overrideConfig.sessionId parameter before using it in MongoDB queries within the MongoDBMemory node. Unauthenticated attackers can submit MongoDB operator objects through the prediction API to read chat history records belonging to other users from the shared collection.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Flowise (FlowiseAI) Fixed in 3.1.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
FlowiseAI Flowise 3.1.4
10 records Highest priority Priority HIGH 5 HIGH, 2 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2026-62067 Flowise before 3.1.4 Remote Code Execution via cwd ParameterPriority HIGH 74
- TI-2026-62066 Flowise before 3.1.4 Remote Code Execution via Custom MCP npxPriority HIGH 74
- TI-2026-62070 Flowise before 3.1.4 SSRF and API Key Exfiltration via Chat Model NodesPriority HIGH 73
Timeline
- 2026-10-02 Threatist record created from CVE-2026-91937
- 2026-10-03 Alias added: GHSA-pcg8-jx3g-5wm7
References
More FlowiseAI vulnerabilities
- TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
- TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
- TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
- TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
Sources
- CVE-2026-91937 · CVE Program
- CVE-2026-91937 · NVD
- FIRST EPSS
- GHSA-pcg8-jx3g-5wm7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences