Path traversal in Octopus Server
Priority MEDIUM 41CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
In affected versions of Octopus Server, a user with permission to modify non built-in external feeds could exploit a path traversal flaw to overwrite arbitrary files on the server, which in some configurations could lead to remote code execution.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00685 52nd percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2026.1.11725, 2026.2.13344, 2026.3.11816
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 2024.1.4131 to before 2026.1.11725; 2026.2.0 to before 2026.2.13344; 2026.3.0 to before 2026.3.11816 | 2026.1.11725, 2026.2.13344, 2026.3.11816 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 2024.1.4131 to before 2026.1.11725; 2026.2.0 to before 2026.2.13344; 2026.3.0 to before 2026.3.11816 Fixed in 2026.1.11725, 2026.2.13344, 2026.3.11816 Patch available CNA
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2026.1.11725, 2026.2.13344, 2026.3.11816
Timeline
- 2026-10-02 Threatist record created from CVE-2026-92355
- 2026-10-03 Alias added: GHSA-7f5m-mqg8-7jjg
References
More Octopus Deploy vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2021-11816 Deserialization of untrusted data in Octopus Deploy Halibut CVSS 3.1CRITICAL 9.8
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-92355 · CVE Program
- CVE-2026-92355 · NVD
- FIRST EPSS
- GHSA-7f5m-mqg8-7jjg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences