Query injection in LangChain @langchain/redis RediSearch filters
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
LangChain packages before 1.1.1, including @langchain/redis, are affected. The @langchain/redis package does not escape attacker-controlled values in structured RediSearch TAG and TEXT filters (CWE-943), so injected RediSearch syntax can alter the generated search query. A remote attacker with low privileges can broaden the query when an application uses such a filter as a tenant or document-access boundary, exposing indexed documents outside their intended scope.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
LangChain is a framework for building LLM-powered applications. Prior to 1.1.1, @langchain/redis does not escape attacker-controlled values in structured RediSearch TAG filters and structured RediSearch TEXT filters, allowing injected RediSearch syntax to alter or broaden the generated search query. When an application uses an attacker-influenceable filter as a tenant or document-access boundary, the modified query can expose indexed documents outside the attacker's intended scope. This issue is fixed in version 1.1.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| langchain-ai | langchainjs | before 1.1.1 | 1.1.1 | Patch available | CNA |
| langchain-ai | redis | before 1.1.1 | 1.1.1 | Patch available | CNA |
| — | @langchain/redis (npm) | before 1.1.1 | 1.1.1 | Patch available | GHSA-5x6v-p487-7qh2 |
- langchainjs Vendorlangchain-ai Affected before 1.1.1 Fixed in 1.1.1 Patch available CNA
- redis Vendorlangchain-ai Affected before 1.1.1 Fixed in 1.1.1 Patch available CNA
- @langchain/redis (npm) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-5x6v-p487-7qh2
Remediation
Upgrade @langchain/redis to version 1.1.1, which fixes this issue. The sources list no fixed version for langchainjs or for @langchain redis.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA langchainjs (langchain-ai) Fixed in 1.1.1
- Fix · CNA redis (@langchain) Fixed in 1.1.1
- Fix · GHSA-5x6v-p487-7qh2 @langchain/redis (npm) Fixed in 1.1.1 Advisory →
Timeline
- 2026-10-06 Threatist record created from CVE-2026-105799
- 2026-10-06 Alias added: GHSA-5x6v-p487-7qh2
- 2026-10-06 Fix available: npm/@langchain/[email protected] · GHSA-5x6v-p487-7qh2
- 2026-10-06 CVSS score added · GHSA-5x6v-p487-7qh2
- 2026-10-06 Weakness changed · GHSA-5x6v-p487-7qh2
- 2026-10-06 6 new references · GHSA-5x6v-p487-7qh2
- 2026-10-06 CISA SSVC decision points changed
References
Other 5
- https://github.com/langchain-ai/langchainjs/security/advisories/GHSA-5x6v-p487-7qh2
- https://github.com/langchain-ai/langchainjs/pull/10701
- https://github.com/langchain-ai/langchainjs/commit/880e3969ea643a2147777a4d5e8bd606a697edf7
- https://github.com/langchain-ai/langchainjs/releases/tag/@langchain/[email protected]
- https://github.com/langchain-ai/langchainjs
More langchain-ai vulnerabilities
- TI-2024-31340 langchain_experimental (aka LangChain Experimental) 0.1.17 through 0.3.0 for LangChain… CVSS 3.1CRITICAL 9.8
- TI-2023-20724 An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20706 An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2023-20166 An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20136 An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter. CVSS 3.1CRITICAL 9.8
- TI-2023-18185 An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-105799 · CVE Program
- CVE-2026-105799 · NVD
- FIRST EPSS
- GHSA-5x6v-p487-7qh2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences