An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a…
Priority HIGH 82CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a JSON file to load_prompt. This is related to __subclasses__ or a template.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.03412 88th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed langchain (PyPI): 0.0.312
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | langchain (PyPI) | before 0.0.312 | 0.0.312 | Patch available | GHSA-7gfq-f96f-g85j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- langchain (PyPI) Vendor— Affected before 0.0.312 Fixed in 0.0.312 Patch available GHSA-7gfq-f96f-g85j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:langchain:langchain:0.0.171:*:*:*:*:*:*:* | 0.0.171 | Vulnerable | langchain-ai |
- cpe:2.3:a:langchain:langchain:0.0.171:*:*:*:*:*:*:* Versions 0.0.171 Vulnerable ·langchain-ai
Remediation
- Fix · GHSA-7gfq-f96f-g85j langchain (PyPI) Fixed in 0.0.312 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-36281
- 2026-10-03 Alias added: GHSA-7gfq-f96f-g85j
References
Exploit 2
Other 5
- https://github.com/langchain-ai/langchain/releases/tag/v0.0.312
- https://github.com/langchain-ai/langchain/pull/10252
- https://github.com/langchain-ai/langchain/commit/22abeb9f6cc555591bf8e92b5e328e43aa07ff6c
- https://github.com/langchain-ai/langchain
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-151.yaml
More langchain-ai Langchain vulnerabilities
- TI-2023-20724 An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20706 An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2023-20166 An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20136 An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter. CVSS 3.1CRITICAL 9.8
- TI-2023-18176 An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because… CVSS 3.1CRITICAL 9.8
- TI-2023-18150 An issue in langchain v.0.0.64 allows a remote attacker to execute arbitrary code via the… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-36281 · CVE Program
- CVE-2023-36281 · NVD
- FIRST EPSS
- GHSA-7gfq-f96f-g85j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences