Read the docs
TI-2023-20724 Aliases CVE-2023-39659GHSA-prgp-w7vf-ch62

An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to…

Priority HIGH 82CWE-74Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to execute arbitrary code via a crafted script to the PythonAstREPLTool._run component.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01521 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed langchain (PyPI): 0.0.325

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—langchain (PyPI)before 0.0.3250.0.325Patch availableGHSA-prgp-w7vf-ch62
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • langchain (PyPI) Vendor— Affected before 0.0.325 Fixed in 0.0.325 Patch available GHSA-prgp-w7vf-ch62

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:langchain:langchain:*:*:*:*:*:*:*:*up to 0.0.232Vulnerablelangchain-ai
  • cpe:2.3:a:langchain:langchain:*:*:*:*:*:*:*:* Versions up to 0.0.232 Vulnerable ·langchain-ai

Remediation

  • Fix · GHSA-prgp-w7vf-ch62 langchain (PyPI) Fixed in 0.0.325 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-39659
  2. 2026-10-03 Alias added: GHSA-prgp-w7vf-ch62

References

  • TI-2023-20706 An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
  • TI-2023-20166 An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
  • TI-2023-20136 An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter. CVSS 3.1CRITICAL 9.8
  • TI-2023-18185 An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a… CVSS 3.1CRITICAL 9.8
  • TI-2023-18176 An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because… CVSS 3.1CRITICAL 9.8
  • TI-2023-18150 An issue in langchain v.0.0.64 allows a remote attacker to execute arbitrary code via the… CVSS 3.1CRITICAL 9.8
See all 27 →

Sources