Priority HIGH 82
langchain_experimental (aka LangChain Experimental) 0.1.17 through 0.3.0 for LangChain allows attackers to execute arbitrary code through sympy.sympify (which uses eval) in LLMSymbolicMathChain.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01387 · Published 2024-09-19 · No fix listed CWE-20
Priority HIGH 82
An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to execute arbitrary code via a crafted script to the PythonAstREPLTool._run component.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01521 · Published 2023-08-15 · Fixed in 0.0.325 CWE-74
Priority HIGH 82
An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr library.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.016 · Published 2023-09-01 · Fixed in 0.0.308, 2.8.5 CWE-94
Priority HIGH 82
An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to execute arbitrary code via the from_math_prompt and from_colored_object_prompt functions.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01822 · Published 2023-08-15 · Fixed in 0.0.236 CWE-74
Priority HIGH 82
An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01405 · Published 2023-08-15 · Fixed in 0.0.247 CWE-94
Priority HIGH 82
An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a JSON file to load_prompt.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03412 · Published 2023-08-22 · Fixed in 0.0.312 CWE-94
Priority HIGH 82
An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because Python code with os.system, exec, or eval can be used.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01065 · Published 2023-07-03 · Fixed in 0.0.247 CWE-94
Priority HIGH 82
An issue in langchain v.0.0.64 allows a remote attacker to execute arbitrary code via the PALChain parameter in the Python exec method.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0188 · Published 2023-07-06 · Fixed in 0.0.247 CWE-74
Priority HIGH 82
An issue in Harrison Chase langchain v.0.0.194 allows an attacker to execute arbitrary code via the python exec calls in the PALChain, affected functions include from_math_prompt and from_colored_object_prompt.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0117 · Published 2023-08-05 · Fixed in 0.0.236 CWE-94
Priority HIGH 82
Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00935 · Published 2023-06-20 · Fixed in 0.0.247
Priority HIGH 79
LangChain is a framework for building agents and LLM-powered applications.
CVSS 3.1CRITICAL 9.3· Network · No auth · No interaction · EPSS 0.4293 · Published 2025-12-23 · Fixed in 1.2.5, 0.3.81 CWE-502
Priority HIGH 78
LangChain is a framework for building LLM-powered applications.
CVSS 3.1CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.00793 · Published 2025-12-23 · Partial fix · 1.1.8, 0.3.80 +2 CWE-502
Priority HIGH 77
LangChain versions up to and including 0.3.1 contain a regular expression denial-of-service (ReDoS) vulnerability in the MRKLOutputParser.parse() method (libs/langchain/langchain/agents/mrkl/output_parser.py).
CVSS 4.0HIGH 8.7· Network · No auth · No interaction · EPSS 0.00481 · Published 2026-01-12 · Will not fix CWE-1333
Priority HIGH 76
A Server-Side Request Forgery (SSRF) vulnerability exists in the RequestsToolkit component of the langchain-community package (specifically, langchain_community.agent_toolkits.openapi.toolkit.RequestsToolkit) in langchai…
CVSS 3.1CRITICAL 10.0· Network · No auth · No interaction · EPSS 0.21019 · Published 2025-06-23 · Fixed in 0.0.28 CWE-918
Priority HIGH 76
In LangChain through 0.0.131, the LLMMathChain chain allows prompt injection attacks that can execute arbitrary code via the Python exec method.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.39653 · Published 2023-04-05 · No fix listed CWE-74
Priority HIGH 75
LangSmith Client SDKs provide SDK's for interacting with the LangSmith platform.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00325 · Published 2026-04-10 · Fixed in 0.5.18 CWE-1321
Priority HIGH 75
A vulnerability in the GraphCypherQAChain class of langchain-ai/langchain version 0.2.5 allows for SQL injection through prompt injection.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.13738 · Published 2024-10-29 · Partial fix · 0.3.0, 0.2.19 +1 CWE-89
Priority HIGH 75
A vulnerability in the GraphCypherQAChain class of langchain-ai/langchainjs versions 0.2.5 and all versions with this class allows for prompt injection, leading to SQL injection.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00311 · Published 2024-10-29 · Fixed in 0.3.1, 0.3.3 CWE-89
Priority HIGH 73
SitemapLoader.parse_sitemap in langchain_community/document_loaders/sitemap.py applies the documented restrict_to_same_domain control only to leaf url entries.
CVSS 4.0HIGH 7.7· Network · No auth · No interaction · EPSS 0.00604 · Published 2026-08-20 · Partial fix CWE-918
Priority HIGH 72
LangChain is a framework for building agents and LLM-powered applications.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01436 · Published 2026-03-31 · Partial fix · 1.2.22 CWE-22
Priority HIGH 72
The HTMLSectionSplitter class in langchain-text-splitters version 0.3.8 is vulnerable to XML External Entity (XXE) attacks due to unsafe XSLT parsing.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.00508 · Published 2025-10-06 · Partial fix · 0.3.9 CWE-611
Priority HIGH 72
A path traversal vulnerability exists in the `getFullPath` method of langchain-ai/langchainjs version 0.2.5.
CVSS 3.1CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.00557 · Published 2024-10-29 · Fixed in 0.2.19 CWE-29
Priority HIGH 71
langchain-ai/langchain is vulnerable to path traversal due to improper limitation of a pathname to a restricted directory ('Path Traversal') in its LocalFileStore functionality.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01871 · Published 2024-04-16 · Fixed in 0.0.353 CWE-22
Priority HIGH 70
LangChain through 0.1.10 allows ../ directory traversal by an actor who is able to control the final part of the path parameter in a load_chain call.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.01726 · Published 2024-03-03 · Fixed in 0.0.339, 0.1.30 CWE-31
Priority HIGH 70
LangChain before 0.0.317 allows SSRF via document_loaders/recursive_url_loader.py because crawling can proceed from an external server to an internal server.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.47625 · Published 2023-10-19 · Fixed in 0.0.317 CWE-918
Load more