Privilege escalation in Octopus Server through improper role validation
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
In Octopus Deploy Octopus Server from 2023.2.945 before 2026.1.11768, from 2026.2.0 before 2026.2.13408, and from 2026.3.0 before 2026.3.15816, an authenticated user with permission to modify roles can bypass protections against access abuse and gain privileges. The flaw is improper validation of unsafe equivalence in input (CWE-1289), which lets the built-in role be weakened and the attacker's account added to a privileged team. Exploitation requires low privileges and needs no user interaction, and the CVSS 4.0 base score is 8.7.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
In affected versions of Octopus Server, an authenticated user with permission to modify roles could bypass the protections preventing access abuse resulting in privilege escalation. It was possible for the built-in role to be weakened and the attacker's account added to a privileged team. This was achievable due to improper validation of unsafe equivalence in inputs.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 2023.2.945 to before 2026.1.11768; 2026.2.0 to before 2026.2.13408; 2026.3.0 to before 2026.3.15816 | 2026.1.11768, 2026.2.13408, 2026.3.15816 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 2023.2.945 to before 2026.1.11768; 2026.2.0 to before 2026.2.13408; 2026.3.0 to before 2026.3.15816 Fixed in 2026.1.11768, 2026.2.13408, 2026.3.15816 Patch available CNA
Remediation
Upgrade Octopus Server to 2026.1.11768, 2026.2.13408, or 2026.3.15816, depending on the release branch in use. The sources list no advisory identifier for this fix.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2026.1.11768, 2026.2.13408, 2026.3.15816
Timeline
- 2026-10-07 Threatist record created from CVE-2026-102478
- 2026-10-07 Alias added: GHSA-r946-p43h-mw8h
- 2026-10-07 CISA SSVC decision points changed
- 2026-10-07 Priority changed: MEDIUM → LOW
References
More Octopus Deploy vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2021-11816 Deserialization of untrusted data in Octopus Deploy Halibut CVSS 3.1CRITICAL 9.8
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-102478 · CVE Program
- CVE-2026-102478 · NVD
- FIRST EPSS
- GHSA-r946-p43h-mw8h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences