Read the docs

Cross-site request forgery in Contao backend actions

Priority LOW 16CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

Contao from 4.0.0 before 5.3.50 and from 5.4.0-RC1 before 5.7.12 fails to validate the request token for backend actions dispatched through the key parameter. Its RequestTokenListener checks the token only for POST requests, so an authenticated backend user who opens an attacker-controlled URL can trigger state-changing actions without a CSRF token (CWE-352). Reachable actions are limited to the modules available to that user. The advisory describes destructive actions, not privilege escalation.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

Description from the CNA

Contao is an Open Source CMS. From version 4.0.0 until 5.3.50 and 5.7.12, RequestTokenListener validates REQUEST_TOKEN only for POST requests, while the declarative GET guard runs only when an act parameter is present. Backend actions dispatched through the key parameter can therefore execute without a CSRF token when an authenticated backend user loads an attacker-controlled URL. Reachable actions remain limited to modules available to that user, and the advisory demonstrates destructive or state-changing actions rather than privilege escalation. This issue is fixed in versions 5.3.50 and 5.7.12.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00115 1st percentileScored 2026-11-07
Fix Fixed contao (contao): 5.3.50, 5.7.12contao/core-bundle (Packagist): 5.3.50, 5.7.12

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
contaocontao4.0.0 to before 5.3.50; 5.4.0-RC1 to before 5.7.125.3.50, 5.7.12Patch availableCNA
—contao/core-bundle (Packagist)4.0.0 to before 5.3.505.3.50Patch availableGHSA-9ff2-p842-45wq
—contao/core-bundle (Packagist)5.4.0-RC1 to before 5.7.125.7.12Patch availableGHSA-9ff2-p842-45wq
  • contao Vendorcontao Affected 4.0.0 to before 5.3.50; 5.4.0-RC1 to before 5.7.12 Fixed in 5.3.50, 5.7.12 Patch available CNA
  • contao/core-bundle (Packagist) Vendor— Affected 4.0.0 to before 5.3.50 Fixed in 5.3.50 Patch available GHSA-9ff2-p842-45wq
  • contao/core-bundle (Packagist) Vendor— Affected 5.4.0-RC1 to before 5.7.12 Fixed in 5.7.12 Patch available GHSA-9ff2-p842-45wq

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:*——contao
  • cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions — — ·contao

Remediation

Update contao/core-bundle to version 5.3.50 or to version 5.7.12.

Written with Claude Haiku 5.5 from the sources below · 2026-10-29

  • Fix · CNA contao (contao) Fixed in 5.3.50, 5.7.12
  • Fix · GHSA-9ff2-p842-45wq contao/core-bundle (Packagist) Fixed in 5.3.50 Advisory →
  • Fix · GHSA-9ff2-p842-45wq contao/core-bundle (Packagist) Fixed in 5.7.12 Advisory →

Timeline

  1. 2026-10-10 Threatist record created from CVE-2026-107848
  2. 2026-10-10 Alias added: GHSA-9ff2-p842-45wq
  3. 2026-10-10 Fix available: Packagist/contao/[email protected], Packagist/contao/[email protected] · GHSA-9ff2-p842-45wq
  4. 2026-10-10 CVSS score added · GHSA-9ff2-p842-45wq
  5. 2026-10-10 Weakness changed · GHSA-9ff2-p842-45wq
  6. 2026-10-10 4 new references · GHSA-9ff2-p842-45wq
  7. 2026-10-13 CISA SSVC decision points changed

References

  • TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
  • TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
  • TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
  • TI-2014-01453 Contao CMS through 3.2.4 has PHP Object Injection Vulnerabilities CVSS 3.1CRITICAL 9.8
  • TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
  • TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
See all 52 →

Sources