Missing auth_time validation in Auth0 auth0.js
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-613.
Summary
The auth0.js library from Auth0 from 9.12.0 before 10.3.0 does not validate the auth_time claim in the ID token against the maxAge value passed to the authorize() method. An application may therefore accept an ID token that represents an authentication event older than the requested maximum age. This is classified as CWE-613 (insufficient session expiration). An attacker with low privileges on the network can exploit it without user interaction, which affects confidentiality and integrity.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
When the authorize() method is called with a maxAge parameter, the auth0.js library does not validate the auth_time claim in the resulting ID token against the requested maxAge value. As a result, an application may process an ID token that represents an authentication event older than the requested maximum age.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade auth0.js to version 10.3.0 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA auth0.js (Auth0) Fixed in 10.3.0
Timeline
- 2026-10-13 Threatist record created from CVE-2026-107371
- 2026-10-14 Priority changed: MEDIUM → LOW
- 2026-10-15 CISA SSVC decision points changed
References
More auth0 vulnerabilities
- TI-2015-07615 Improper input validation in HackerOne jsonwebtoken node module CVSS 3.0CRITICAL 9.8
- TI-2025-29805 Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK CVSS 3.1CRITICAL 9.1
- TI-2025-31089 Auth0-PHP SDK Deserialization of Untrusted Data vulnerability CVSS 4.0CRITICAL 9.3
- TI-2020-06427 An issue was discovered in the Login by Auth0 plugin before 4.0.0 for WordPress. CVSS 3.1CRITICAL 9.8
- TI-2018-05020 The Auth0 authentication service before 2017-10-15 allows privilege escalation because… CVSS 3.0CRITICAL 9.8
- TI-2019-05387 Auth0 Auth0-WCF-Service-JWT before 1.0.4 leaks the expected JWT signature in an error… CVSS 3.0CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences