Missing authorization in Elementor exposes private post content
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Elementor Website Builder plugin for WordPress is affected in all versions up to and including 4.2.3. A missing authorization check (CWE-862) lets authenticated users with Contributor access or higher read data they should not see. Such attackers can extract the full post content and plaintext password of private, draft, pending, and future posts written by any author, including Administrators and Editors, through the keys_conversion_map parameter.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Elementor Website Builder – more than just a page builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.3 via the 'keys_conversion_map' parameter. This makes it possible for authenticated attackers, with contributor-level access and above, to extract the full post_content and plaintext post_password of private, draft, pending, and future posts belonging to any author, including Administrators and Editors.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The sources list no fixed version for Elementor Website Builder.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-15 Threatist record created from CVE-2026-11905
- 2026-10-16 Alias added: GHSA-pg25-hg39-vr7m
- 2026-10-16 CISA SSVC decision points changed
References
Other 10
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4a018a58-2184-4031-99a8-4aad55bcc815?source=cve
- https://plugins.trac.wordpress.org/browser/elementor/tags/4.1.2/modules/wp-rest/classes/post-query.php#L71
- https://plugins.trac.wordpress.org/browser/elementor/tags/4.1.2/modules/wp-rest/classes/post-query.php#L62
- https://plugins.trac.wordpress.org/browser/elementor/tags/4.1.2/modules/wp-rest/classes/post-query.php#L108
- https://plugins.trac.wordpress.org/browser/elementor/tags/4.1.2/modules/wp-rest/base/query.php#L106
- https://plugins.trac.wordpress.org/browser/elementor/tags/4.0.3/modules/wp-rest/classes/post-query.php#L71
- https://plugins.trac.wordpress.org/browser/elementor/tags/4.0.3/modules/wp-rest/classes/post-query.php#L62
- https://plugins.trac.wordpress.org/browser/elementor/tags/4.0.3/modules/wp-rest/classes/post-query.php#L108
- https://plugins.trac.wordpress.org/browser/elementor/tags/4.0.3/modules/wp-rest/base/query.php#L106
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3674524%40elementor&new=3674524%40elementor
More Elementor vulnerabilities
- TI-2022-01211 Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution CVSS 3.1HIGH 8.8
- TI-2023-00313 Elementor Website Builder < 3.12.2 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2026-06653 Temporary Login <= 1.0.0 - Authentication Bypass to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2023-02927 Elementor Pro <= 3.11.6 - Authenticated(Subscriber+) Privilege Escalation via update_page_option CVSS 3.1HIGH 8.8
- TI-2020-10317 An issue was discovered in the Elementor Pro plugin before 2.9.4 for WordPress, as… CVSS 3.1CRITICAL 9.9
- TI-2023-25675 WordPress Elementor plugin <= 3.16.4 - Auth. Arbitrary Attachment Read vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-11905 · CVE Program
- CVE-2026-11905 · NVD
- FIRST EPSS
- GHSA-pg25-hg39-vr7m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences