Privilege escalation in WholesaleX lets attackers register as any role
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
WholesaleX (All-in-One B2B Solution with Wholesale Pricing by wpxpo) is affected in versions from 0 through 3.0.8. The process_registration function does not validate the wholesalex_registration_role parameter, which is an improper privilege management flaw (CWE-269). An unauthenticated remote attacker can register as any existing WholesaleX role. The vulnerability was partially patched in version 2.3.8.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The WholesaleX – B2B & Wholesale Plugin for WooCommerce with Wholesale Prices plugin for WordPress is vulnerable to Limited Privilege Escalation in all versions up to, and including, 3.0.8 via the 'process_registration' due to missing validation on the 'wholesalex_registration_role' parameter. This makes it possible for unauthenticated attackers to register as any existing WholesaleX role. The vulnerability was partially patched in version 2.3.8.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The sources list no fixed version for WholesaleX.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-16 Threatist record created from CVE-2026-8145
References
Other 5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d3b9464c-dcc4-4ae8-816f-1572f84dfe08?source=cve
- https://plugins.trac.wordpress.org/browser/wholesalex/trunk/includes/menu/class-wholesalex-registration.php#L1327
- https://plugins.trac.wordpress.org/browser/wholesalex/tags/2.3.7/includes/menu/class-wholesalex-registration.php#L1327
- https://plugins.trac.wordpress.org/changeset/3529605/
- https://plugins.trac.wordpress.org/changeset/3703929/
More wpxpo vulnerabilities
- TI-2024-09942 PostX <= 4.1.16 - Missing Authorization to Arbitrary Plugin Installation/Activation CVSS 3.1HIGH 8.8
- TI-2024-04008 PostX < 4.1.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 6.8
- TI-2023-03707 PostX - Gutenberg Post Grid Blocks < 3.0.6 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-20266 WordPress WholesaleX plugin <= 1.3.2 - Unauthenticated Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-19970 WordPress WholesaleX plugin <= 1.3.2 - Unauthenticated PHP Object Injection vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-15553 WordPress ProductX – Gutenberg WooCommerce Blocks Plugin <= 3.1.4 is vulnerable to PHP Object Injection CVSS 3.1CRITICAL 9.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences