Unauthenticated stored XSS in CP Multi View Events Calendar plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The CP Multi View Events Calendar plugin for WordPress is affected in all versions up to and including 1.4.42. It does not properly sanitize or escape the CalendarTitle parameter, which causes a stored cross-site scripting flaw (CWE-79). An unauthenticated attacker can inject web scripts into pages that run whenever a user opens the injected page, but only when an administrator has enabled the frontend edition option on at least one calendar view.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'CalendarTitle' parameter in all versions up to, and including, 1.4.42 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires that an administrator has enabled the "Allow edition in frontend?" option on at least one calendar view, which exposes the unauthenticated add endpoint and a publicly accessible nonce.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| codepeople | CP Multi View Events Calendar | up to 1.4.42 | — | No fix listed | CNA |
- CP Multi View Events Calendar Vendorcodepeople Affected up to 1.4.42 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for CP Multi View Events Calendar.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-16 Threatist record created from CVE-2026-110701
- 2026-10-16 Alias added: GHSA-h82p-7v3c-q6xw
References
Other 8
- https://www.wordfence.com/threat-intel/vulnerabilities/id/12f2d3d3-4cc1-4569-9183-62f4841e72f7?source=cve
- https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.42/DC_MultiViewCal/src/Plugins/jquery.calendar.js#L2689
- https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.42/php/datafeed.php#L23
- https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.42/php/datafeed.php#L89
- https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.42/cp-multi-view-calendar.php#L32
- https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.42/php/datafeed.php#L340
- https://plugins.trac.wordpress.org/log/cp-multi-view-calendar/
- https://plugins.trac.wordpress.org/changeset/3748683/cp-multi-view-calendar/trunk/DC_MultiViewCal/src/Plugins/jquery.calendar.js
More codepeople vulnerabilities
- TI-2024-00790 Booking Calendar < 1.3.83 - CSRF appointment scheduling CVSS 3.1HIGH 8.8
- TI-2024-11385 BookingPress < 1.1.23 - Unauthenticated Export File Download CVSS 3.1HIGH 7.5
- TI-2024-03387 Smart Image Gallery < 1.0.19 - Update/Delete Google API Key via CSRF CVSS 3.1MEDIUM 6.8
- TI-2023-05486 Contact Form Email < 1.3.44 - Editor+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-08220 Polls CP <= 1.0.75 - Admin+ Stored XSS via Custom Styles CVSS 3.1MEDIUM 5.4
- TI-2024-08217 Polls CP <= 1.0.75 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2026-110701 · CVE Program
- CVE-2026-110701 · NVD
- FIRST EPSS
- GHSA-h82p-7v3c-q6xw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences