Incorrect authorization in phpMyFAQ news update API lets admins edit news
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
phpMyFAQ from 4.0.0 before 4.1.9 contains an incorrect authorization flaw (CWE-863) in the news update API. The PUT /admin/api/news/update endpoint checks the NEWS_DELETE right instead of NEWS_EDIT, so delegated admins without the editnews right can modify news items. An attacker who holds the addnews and delnews rights can read the CSRF token from their own cookie and rewrite the header, body, author, link and active flag of any news item shown on the public front page.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
phpMyFAQ from 4.0.0 before 4.1.9 contains an incorrect authorization vulnerability that allows delegated admins lacking the editnews right to modify news by calling PUT /admin/api/news/update, which checks NEWS_DELETE instead of NEWS_EDIT. Attackers holding addnews and delnews can read the update-news CSRF token from their own cookie and rewrite any news item's header, body, author, link and active flag shown on the public front page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Update phpMyFAQ to version 4.1.9 or later, which fixes the authorization check. The sources do not list a vendor advisory for this fix.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA phpMyFAQ (thorsten) Fixed in 4.1.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
thorsten phpMyFAQ 4.1.9
14 records Highest priority Priority HIGH 5 HIGH, 6 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2026-76118 Authentication bypass in phpMyFAQ via WebAuthn credential injectionPriority HIGH 81
- TI-2026-76115 Authorization bypass in phpMyFAQ REST API edits restricted FAQsPriority HIGH 73
- TI-2026-76092 phpMyFAQ e-mail change lacks password check, enabling takeoverPriority HIGH 73
Timeline
- 2026-10-18 Threatist record created from CVE-2026-111888
- 2026-10-18 Alias added: GHSA-j2g3-mcv7-r3f2
References
More thorsten vulnerabilities
- TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2026-76118 Authentication bypass in phpMyFAQ via WebAuthn credential injection CVSS 4.0CRITICAL 9.3
- TI-2026-32868 phpMyFAQ - Unauthenticated Two-Factor Authentication Brute-Force via /admin/check Endpoint CVSS 4.0CRITICAL 9.3
- TI-2026-76108 Unauthenticated denial of service in phpMyFAQ API pagination CVSS 4.0HIGH 8.7
- TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
- TI-2026-34083 phpMyFAQ - Unauthenticated Information Disclosure via getIdFromSolutionId Permission Bypass CVSS 4.0HIGH 8.7
Sources
- CVE-2026-111888 · CVE Program
- CVE-2026-111888 · NVD
- FIRST EPSS
- GHSA-j2g3-mcv7-r3f2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences