Privilege escalation in phpMyFAQ via updateUserRights
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
phpMyFAQ from 4.2.0-alpha.2 before 4.2.0-beta has a privilege escalation flaw in UserController::updateUserRights, which drops per-right language restrictions when rights are granted again. An administrator with USER_EDIT can submit language-scoped rights to the update-rights API, including for their own account, to gain unrestricted create, edit and publish access to FAQs in all languages. The CVSS 4.0 vector requires high privileges over the network with low complexity and no user interaction. A public proof of concept is reported in CISA's SSVC data, but the flaw is not listed in CISA KEV.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
phpMyFAQ from 4.2.0-alpha.2 before 4.2.0-beta contains a privilege escalation vulnerability in UserController::updateUserRights that drops per-right language restrictions when rights are re-granted. Administrators holding USER_EDIT can submit language-scoped rights to the update-rights API, including for themselves, to gain unrestricted FAQ create, edit, and publish access across all languages.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade phpMyFAQ to version 4.2.0-beta or later, which fixes the flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA phpMyFAQ (thorsten) Fixed in 4.2.0-beta
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
thorsten phpMyFAQ 4.2.0-beta
24 records Highest priority Priority HIGH 10 HIGH, 10 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2026-76108 Unauthenticated denial of service in phpMyFAQ API paginationPriority HIGH 77
- TI-2026-76115 Authorization bypass in phpMyFAQ REST API edits restricted FAQsPriority HIGH 73
- TI-2026-76092 phpMyFAQ e-mail change lacks password check, enabling takeoverPriority HIGH 73
Timeline
- 2026-10-18 Threatist record created from CVE-2026-111890
- 2026-10-18 Alias added: GHSA-x3mg-fj9x-7cq2
- 2026-10-18 Priority changed: MEDIUM → LOW
- 2026-10-19 CISA SSVC decision points changed
- 2026-10-19 Priority changed: LOW → MEDIUM
References
More thorsten vulnerabilities
- TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2026-76118 Authentication bypass in phpMyFAQ via WebAuthn credential injection CVSS 4.0CRITICAL 9.3
- TI-2026-32868 phpMyFAQ - Unauthenticated Two-Factor Authentication Brute-Force via /admin/check Endpoint CVSS 4.0CRITICAL 9.3
- TI-2026-76108 Unauthenticated denial of service in phpMyFAQ API pagination CVSS 4.0HIGH 8.7
- TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
- TI-2026-34083 phpMyFAQ - Unauthenticated Information Disclosure via getIdFromSolutionId Permission Bypass CVSS 4.0HIGH 8.7
Sources
- CVE-2026-111890 · CVE Program
- CVE-2026-111890 · NVD
- FIRST EPSS
- GHSA-x3mg-fj9x-7cq2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences