Privilege escalation in phpMyFAQ group permissions API
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
phpMyFAQ from 4.2.0-alpha.2 before 4.2.0-beta contains a privilege escalation flaw in its group permission API, where the updatePermissions and updateMembers endpoints check held rights without regard to language or category scope. A non-superadmin administrator with GROUP_EDIT can grant a group a right they hold only in a narrow scope and then add themselves to that group. This gives unrestricted FAQ create, edit and publish access across all languages and categories. The flaw is classified as CWE-269 and requires high privileges over the network, with low complexity.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
phpMyFAQ from 4.2.0-alpha.2 before 4.2.0-beta contains a privilege escalation vulnerability in the group permission API, whose updatePermissions and updateMembers endpoints check held rights without regard to language or category scope and write unrestricted group grants. Non-superadmin administrators holding GROUP_EDIT can grant a group a right they hold only in a narrow scope and self-join it via updateMembers, gaining unrestricted FAQ create, edit, and publish access across all languages and categories.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade phpMyFAQ to version 4.2.0-beta or later. The sources list no fixed version other than 4.2.0-beta for phpMyFAQ.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA phpMyFAQ (thorsten) Fixed in 4.2.0-beta
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
thorsten phpMyFAQ 4.2.0-beta
24 records Highest priority Priority HIGH 10 HIGH, 10 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2026-76108 Unauthenticated denial of service in phpMyFAQ API paginationPriority HIGH 77
- TI-2026-76115 Authorization bypass in phpMyFAQ REST API edits restricted FAQsPriority HIGH 73
- TI-2026-76092 phpMyFAQ e-mail change lacks password check, enabling takeoverPriority HIGH 73
Timeline
- 2026-10-18 Threatist record created from CVE-2026-111891
- 2026-10-18 Alias added: GHSA-vj43-979m-cpx8
- 2026-10-18 Priority changed: MEDIUM → LOW
- 2026-10-19 CISA SSVC decision points changed
References
More thorsten vulnerabilities
- TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
- TI-2026-76118 Authentication bypass in phpMyFAQ via WebAuthn credential injection CVSS 4.0CRITICAL 9.3
- TI-2026-32868 phpMyFAQ - Unauthenticated Two-Factor Authentication Brute-Force via /admin/check Endpoint CVSS 4.0CRITICAL 9.3
- TI-2026-76108 Unauthenticated denial of service in phpMyFAQ API pagination CVSS 4.0HIGH 8.7
- TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
- TI-2026-34083 phpMyFAQ - Unauthenticated Information Disclosure via getIdFromSolutionId Permission Bypass CVSS 4.0HIGH 8.7
Sources
- CVE-2026-111891 · CVE Program
- CVE-2026-111891 · NVD
- FIRST EPSS
- GHSA-vj43-979m-cpx8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences