Read the docs

Missing authorization in phpMyFAQ lets users delete superadmin accounts

Priority LOW 31CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Privilege escalation
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-269.

Summary

phpMyFAQ before 4.1.9 contains a missing authorization flaw in its deleteUser() API, classified as CWE-269 (Improper Privilege Management). An authenticated user with the delete_user permission who is not a superadmin can delete superadmin accounts other than user ID 1. The attack needs low privileges and no user interaction, and it can remove administrative access and accountability.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

Description from the CNA

phpMyFAQ before 4.1.9 contains a missing authorization vulnerability in the deleteUser() API that allows authenticated non-superadmin users with delete_user permission to delete superadmin accounts. Attackers can send a DELETE request to /admin/api/user/delete with a superadmin's userId other than 1, removing administrative access and accountability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00275 19th percentileScored 2026-11-07
Fix Fixed phpMyFAQ (thorsten): 4.1.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
thorstenphpMyFAQbefore 4.1.94.1.9Patch availableCNA
  • phpMyFAQ Vendorthorsten Affected before 4.1.9 Fixed in 4.1.9 Patch available CNA

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:*——thorsten
  • cpe:2.3:a:phpmyfaq:phpmyfaq:*:*:*:*:*:*:*:* Versions — — ·thorsten

Remediation

Upgrade phpMyFAQ to version 4.1.9 or later, which fixes this issue.

Written with Claude Haiku 5.5 from the sources below · 2026-10-28

  • Fix · CNA phpMyFAQ (thorsten) Fixed in 4.1.9

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    thorsten phpMyFAQ 4.1.9

    14 records Highest priority Priority HIGH 5 HIGH, 6 MEDIUM, 3 LOW

    Other records, highest priority first

    • TI-2026-76118 Authentication bypass in phpMyFAQ via WebAuthn credential injectionPriority HIGH 81
    • TI-2026-76115 Authorization bypass in phpMyFAQ REST API edits restricted FAQsPriority HIGH 73
    • TI-2026-76092 phpMyFAQ e-mail change lacks password check, enabling takeoverPriority HIGH 73

Timeline

  1. 2026-10-18 Threatist record created from CVE-2026-111909
  2. 2026-10-18 Alias added: GHSA-2jrh-wx9p-9fp9

References

  • TI-2023-00296 Improper Authentication in thorsten/phpmyfaq CVSS 3.1CRITICAL 9.8
  • TI-2026-76118 Authentication bypass in phpMyFAQ via WebAuthn credential injection CVSS 4.0CRITICAL 9.3
  • TI-2026-32868 phpMyFAQ - Unauthenticated Two-Factor Authentication Brute-Force via /admin/check Endpoint CVSS 4.0CRITICAL 9.3
  • TI-2026-76108 Unauthenticated denial of service in phpMyFAQ API pagination CVSS 4.0HIGH 8.7
  • TI-2026-53313 phpMyFAQ 3.1.0 through 4.1.6 Authentication Bypass via LDAP CVSS 4.0HIGH 8.8
  • TI-2026-34083 phpMyFAQ - Unauthenticated Information Disclosure via getIdFromSolutionId Permission Bypass CVSS 4.0HIGH 8.7
See all 224 →

Sources